Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - tv033

Pages: [1]
1
General Discussion / Re: Terrain Importer for Unity
« on: October 13, 2014, 09:30:08 AM »
You can certainly use the default import method to import your height map and then use the free splat map import tool to import your splat map; you'll just have to do so for each individual tile, which may not be a problem if you're only importing your tile set once. If you find yourself making adjustments in World Machine and needing to re import the height/splat maps into Unity, it can get tiresome.

So no, my tool is not required, but it makes the process faster and easier.


2
General Discussion / Terrain Importer for Unity
« on: October 07, 2014, 03:30:51 PM »
Hey everyone!

I created a Terrain Importer for Unity3d recently that has been released on the Unity Asset Store for $5. It was primarily built with World Machine in mind, and can import tile sets (even large sets that exceed the 3.5 GB limit of Unity's Editor can be imported).

More information can be found on the forums at the following link: http://forum.unity3d.com/threads/released-terrain-importer.264640/

You can post your questions here or there. Let me know what you think!

3
Bug Reports and Help / Re: Tiled world to unity
« on: October 07, 2014, 03:27:20 PM »
I have just recently released a package on the Unity Asset store that should ease the import process. It should work with terrains from different programs, but it was primarily built around World Machine. You can import a single heightmap/alpha map or a tiled set.

It's only $5, and if you're going to be importing tile sets repeatedly I highly recommend it. Here's the link to the forum page where you can find more information: http://forum.unity3d.com/threads/released-terrain-importer.264640/

If you're not interested, that's cool. Here are the steps I follow to import my World Machine tile sets into Unity.

Obviously this isn't the only way to go about creating/importing a tile set, but it's the way I do it, and it works well. I am not using World Machine 3 yet, so not sure how it works with it. I'll have to do some testing soon.

This is not a definitive guide; this is just what has worked well for me.

1)    Generate a non tiled heightmap with your tile set in mind. For example, if at the end of this process
   you want a 4 x 4 tile set with each tile having a heightmap resolution of 513, then generate a non tiled
   heightmap with a resolution of 2049.

2)   Generate a splat map the same way, but make the resolution a power of two (rather than a power of two + 1).
   I am not 100% positive this is necessary; you may be able to get a way with a power of two + 1 splatmap.

3)    In an image editing program such as Photoshop, open the generated splatmap and generate four separate images, one for each channel.
   You can use Gimp for this, though Photoshop supports higher texture resolutions. Just google "Creating images from channels," or something
   similar to find out how to performt his step for your image editing software.

4)   Configure your World Machine tile settings.
   
      a) Under Tiling Options, leave the "Share edge vertices" option enabled, but disable all other options.

      b) Change the Tile Resolution and Tile per Side to whatever you desire. Just make sure the settings make sense.
         If your original heightmap is 2049, and Tiles per Side is 4, the Tile Resolution should be 513.

      c) Set Blending Percentage to 0.

      d) Disable Pad coordinate digits. I also recommending changing the "Tiles start numbering at" option to 1 | 1 and
         "Naming string" to _%y_%x, but this is not required. Note that %y = Row and %x = Column when configuring the import settings in Unity (This step is only required when using my tool).

5)   Add a File Input Device and load the heightmap you generated in Step 1. Make sure to choose the "Place from Current" button under
   "World Placement." Hook this up to a Height Output device and configure the output device however you wish. Make sure "Participate
   when building tiled worlds" is enabled, and then run a tiled build by clicking on the Green sphere with the cross on it.

6)   Once your heightmap tiles are generated, it is time to generate your splatmap tiles. Go back to your world machine settings and adjust the
   tile resolution so it is a power of two rather than a power of two + 1.

7)   Add four file input devices, one for each image you generated earlier (for the R, G, B, and A channels). Load each image and press the
   "Place from Current" button.

8)   Hook the R, G, and B File Input Devices to a Channel Combiner Advice, and then run that Channel Combiner Device to a Bitmap Output device (top input).
   Hook the A File Input Device to the bottom input of this same Bitmap Output Device. Configure the Bitmap Output device, making sure that
   "Participate when building tiled worlds" is checked. All other World Machine Settings configured in step 4 can be left the same.
   Run another tiled build.

9) You should now be ready to import the tile set.

4
Bug Reports and Help / Mountain Ridge Issue
« on: June 10, 2014, 09:12:51 PM »
Hello! My problem is simple, and hopefully the solution is relatively straight forward. I have produced a decent looking terrain height map, but the ridges are not to my liking.

The top of the ridge should be at a single height map point, but instead is kind of spread between several different points.

So instead of :
.    .    .    .    .

It's like:
   .    .    .    .
.    .    .    .    .
   .    .    .    .

Hopefully you know what I mean  :D

Project included, along with a in game picture of the ridges from Unity.

Thanks for any help. Please let me know if I need to explain the problem another way.

5
Bug Reports and Help / Re: Mouse pan?
« on: June 09, 2014, 08:58:32 PM »
Oh wow this is old.

Yes, use the arrow keys to pan.

Awesome, that helps quite a bit!

6
Bug Reports and Help / Re: Mouse pan?
« on: May 14, 2014, 08:15:15 PM »
This is very old, but still relevant. Is there any way to pan the camera?

It would make it so much easier to view the terrain in the 3D view. Right now there are some angles that you just can't view the terrain at.

7
General Discussion / Re: Re-scaling terrain by a certain Value
« on: May 14, 2014, 08:12:35 PM »
I am wondering about this too.

I have a map with a max elevation of 7500m. After fiddling with stuff and getting my terrain to look like I want, I realized the max height I'm using is around 2500m, so I have basically 5000m of wasted space.

I'd like to change the max elevation down to 2500m, but if I do this my entire terrain gets lowered.

I understand why this is happening, but I'd love for there to be an option (perhaps a check box) you can enable to have your terrain dimensions remain the same (as much as possible) when changing the elevation.

Maybe there could be a device that scales your height map by a certain amount based on the current elevation values and the previous elevation values (which you'd have to enter yourself obviously).

I'm pretty new to all this, so maybe this isn't possible, but it sure would be cool.

8
Geology and Terrain / Re: (Solved)Crater
« on: December 22, 2013, 07:53:53 PM »
I am wondering the same thing. The macro already has a "Device Origin" option, but it is greyed out. How can we enable this so we can provide x/y coordinates that the macro can use?

9
It was indeed a bitmap output. Great to see you already have a handle on the issue!

10
Hi, is this fixed? I tried exporting a 16 bit png and I ran into an out of memory error, however a 16 bit .tif export works fine, so that leads me to believe this bug is still not fixed. Unless something else is going on. I have 16GB of ram and my page file max is set to 24,xxx (should it be larger?)

I am using a 16385 x 16385 resolution. Thanks!

11
Bug Reports and Help / Re: File Input Questions
« on: November 13, 2013, 10:59:39 AM »
I got it to display the same results as well after moving the equalizer. Thank you so much for the help!

12
Bug Reports and Help / Re: File Input Questions
« on: November 11, 2013, 05:02:56 PM »
Here is another tmd better showing the issue. There are two groups in this tmd, the bottom group is the normal chain found in Splat_Converter.tmd, while the top chain uses file inputs.

There are very slight differences between the two methods, as can be seen when you click on the overview device for each group. Obviously I am doing something wrong with the file input method. Any thoughts?

Thanks again for the quick help. It goes a long way to making me feel confident in my purchase of WM2 Pro, and will definitely encourage me to recommend your product to others!

13
Bug Reports and Help / Re: File Input Questions
« on: November 11, 2013, 04:16:58 PM »
Yes, both the wear and deposition maps are run through separate equalizer and clamp devices before being outputted. I didn't think that would be a problem. They're run through the same devices in the normal Splatmap_Converter chain. Both the equalizer and clamp devices output heightfields, so I was under the impression I was just "saving the chain" with the output device and picking up where I left off from with the file input devices.

Also, I'm pretty sure I originally tried to output the wear and deposition maps directly (without running them through the equalizer and camp devices), and then run the file inputs through those devices. I can't remember exactly what the result was, and I hadn't set the hint to mask at that point, but I don't think it worked correctly.

I am going to do some test with lower resolution to see if I can figure out what's going on. In the mean time, I am providing the .tmd, just be aware, the resolution is currently set to 16385!

14
Bug Reports and Help / Re: File Input Questions
« on: November 11, 2013, 11:27:53 AM »
Thank you for the quick response! I set the mask to hint and it is now displaying correctly in the overview when the file input is selected, but now I can see for sure there is something off. When imported back into WM, the wear and deposition maps have significantly less white in the image. I've attached screenshots showing the wear map output vs input, as well as images showing what the terrain looks like in 3D view when using file inputs for the wear/deposition map, vs what it looks like when using the normal chain without file input devices.

Thanks again for the help!

15
Bug Reports and Help / File Input Questions
« on: November 10, 2013, 08:50:35 PM »
Hello all,

I recently started using WM2, and have been trying to get a high resolution terrain created for use in Unity. I plan on using it solefy for a demo video, so I decided to just try and output the terrain found in the splat map creation project. My end goal is to create an 8x8 set of tiled terrains at 2049 x 2049 resolution each, which as you can probably imagine, will take a day or two. With that in mind, I decided to try and split the creation process into several steps.

The first step was to save the heightfield output after the first erosion and thermal weathering devices to a .r16 file, which was a simple matter.

The next step was to run that file through the second erosion device, and then save the three outputs (primary heightfield, wear map, and deposition map) to their own files. This is where I'm facing a problem. I have the three files, but when I try to bring the wear and deposition maps back into the chain via File Input devices, they don't look like the same maps that were outputted (the maps shown when you click on the Height Output device). Instead of a black/whitish image, a brownish image with spikes is shown, and when I use these inputs to create an overlay, the overlay terrain does not look like it should.

I saved the deposition and wear maps as .r16 files. Is that the correct format for these type of maps, or does it matter? I saw something about doing a y-projection on a wear map input, but I have no idea what that is. The provided images show the device chain and wear map output/input in the 3d-view. Please, any help would be greatly appreciated!

On a side note: I also tried outputting a ARGB splatmap as a bitmap, and then tried to bring it back in via a File Input in order to use it to make a tiled build, however it did not work. If I have a ARGB bitmap, can I just link it to a Bitmap output for use in tiled build? Or do I need to take the bitmap input and split it into A and RGB (via channel splitter), then route those into a new bitmap output (running the RGB into a channel combiner first, seems redundant?)? If so, how do I get the alpha from the bitmap? Thanks!

Pages: [1]