Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - posfan12

Pages: [1]
1
Bug Reports and Help / Slope selector wrong angle
« on: March 26, 2018, 02:09:32 PM »
I set the slope selector maximum to 0.8, and the dialog says that's equal to 51 degrees. However, this is incorrect since a slope of 0.8 equals 39 degrees.

Or maybe the decimal value equals the sine of the angle? But this does not seem to be the case either.

Also, I think it would be great if we could input our own values instead of just using the very imprecise slider.

2
Bug Reports and Help / Can't see mesh in preview window
« on: March 26, 2018, 01:44:06 PM »
If I set a mesh's properties to

Units = Export using meters

then I can no longer see the mesh in the preview window.

Is there a way to automatically zoom to fit the mesh? Thanks.

3
General Discussion / Numerical precision
« on: March 25, 2018, 10:58:00 AM »
I have a terrain that is 128x128 pixels. This means that when exporting the mesh, the coordinates require 7 digits after the decimal place, since 1/128 = 0.0078125. However, formats such as OBJ and STL only support 6 digits after the decimal place, which ends up being lossy.

How can I work around this problem? It would be great if I could scale all the coordinates up such that they do not use any decimal places at all.

Thanks.

4
General Discussion / Road spline export
« on: March 24, 2018, 11:21:10 PM »
It's been a while, and I'm a bit hazy on the subject, but I think there is a tutorial for creating roads using splines?

Can I export/import the control points of a spline to/from a text file? I want to create the actual road surface using a separate tool.

What equations do you use for the splines? IIRC, they are Hermite splines, correct?

Thanks.

5
General Discussion / "Edges" of mesh output
« on: October 30, 2016, 09:17:08 PM »
When you normally view a height map in WM, the sides are "filled in" so you can't peek through. This is not the case for mesh output. Is there a way to configure WM to output those side faces as well?




6
General Discussion / Spline rotation?
« on: October 29, 2016, 07:39:05 PM »
I have added a spline with multiple nodes in my layout generator. Is there a easy way to rotate the whole spline in one step? Thanks.

7
Bug Reports and Help / Clamp Heights in World Machine Units
« on: August 26, 2015, 07:36:08 PM »
This dialog still shows meters. How do I calculate the correct height in World Machine units?

[edit]

Also, I am having trouble entering my own values for clipping. For instance, if I enter 1, the left slider goes all the way to the top next to the right slider.

8
General Discussion / Move or shrink problem area
« on: August 26, 2015, 05:18:49 PM »
I'm pretty happy with how my map is turning out. However, I would like to either shrink or move the big center-right hill a bit further south to make room for my city. Can anyone tell me how to do this?



Thanks!

9
Bug Reports and Help / Layout view grid
« on: August 24, 2015, 02:22:29 PM »
Is it possible to change the grid size in layout view? Currently I can only snap to -1.0, -0.5, 0.0, 0.5, 1.0, etc. as far as I can tell.

[edit]

Is it also possible to input exact coordinates for shapes, such as position, radius, etc.?

10
Bug Reports and Help / Layout view lines
« on: August 24, 2015, 11:49:36 AM »
I'm having problems drawing lines with the Layout view.

1. Firstly, when I start trying it will only draw points with no lines connecting them.
2. Then, after I somehow get them working (I don't know how), it will not stop drawing them even if the Lines brush is not selected. And they don't show up in the hierarchy either.
3. How do I delete lines? I am trying to right-click them but no dice.

Thanks!

[edit]

WM just crashed on me too. Don't know if it managed to send a dump to your server because Windows says it's not responding.

11
Bug Reports and Help / Circles in layout view
« on: August 24, 2015, 11:42:33 AM »
When a circle has a zero radius it is no longer possible to resize or move the circle using the mouse, or delete it using the right-click menu.

WM 2.3.7 Basic 32-bit

12
General Discussion / Layout generator view
« on: August 22, 2015, 08:23:10 PM »
1. How do I delete objects from the layout hierarchy? I tried pressing Delete as well as right-clicking on the list.
2. How do you close the tabs in the layout view? Again, I tried right-clicking on the tab.

Thanks.

[edit]

3. Somehow I messed things up so that I cannot view any objects in the layout generator. The small preview window works fine. How do I fix this?



4. I am trying to draw some lines, but only the unconnected points appear. How do I get the lines (for a river) to show up?
5. Why doesn't "Undo" work in layout view??

13
General Discussion / Turning off smoothing
« on: August 20, 2015, 07:01:08 PM »
Is there a way to disable texture smoothing, especially in the 3D preview? I want my mesh to appear exact and crisp, not smoothed. Thanks.

14
General Discussion / SimCity 2000 style heightmap?
« on: August 18, 2015, 11:16:31 AM »
Hi! I wrote a routine to turn a mesh into a "stepped" variant similar to that found in old isometric video games like SimCity 2000. However, due to the way WM outputs its meshes, there is a limit in terms of the directions diagonal lines can take. See the attached image. Diagonal lines are only possible from the bottom-left to top-right. Diagonal lines are not possible from the top-left to the bottom-right. Is there a way to fix this, maybe by exporting to a different format or setting? Is there a third-party tool I can use to do this? Thanks!

15
General Discussion / Flatten certain areas
« on: August 14, 2015, 04:29:32 AM »
If the slope of a heightmap is less than a certain amount, I would like to completely flatten the terrain, creating a sort of terrace but leaving the rest of the terrain intact. Is this possible in WM?

16
General Discussion / Need to recreate an old Wilbur heightmap
« on: August 11, 2015, 08:41:45 AM »
I created a nice heightmap several years ago in Wilbur, but unfortunately lost it when migrating to a new computer.



I like it because the hills are nice and rounded, there's a flat-ish area in the middle, and the rivers are narrow and deep. Could someone help me by showing me how to recreate this as closely as possible in WM? In particular, I used Wilbur's Fill Basin filter to flatten the valley and I can't figure out how to do this in WM. Also, I haven't figured out how to create the river channels. Thank you.


Mike

17
General Discussion / Mesh for river surface
« on: August 11, 2015, 04:01:30 AM »
I'm dealing with small scales where individual people are visible, and therefore need a mesh (or heightmap I guess) for the river surface itself. I was wondering if you have any tips on how to create the surface for the river? Thanks!

18
Works in Progress / Terrain for Lego project is maybe not flat enough
« on: January 15, 2014, 01:33:30 AM »
I'm working on a community Lego project here:

https://code.google.com/p/datsville/

I created some terrain using WM here:

https://datsville.googlecode.com/svn/trunk/studies/terrain/worldmachine_project.tmd

The scale of the terrain is 1 square per every 32 bricks.

I was wondering if I could get some feedback on the terrain. In particular I would like the flat areas of the terrain to be slightly flatter. But I would appreciate any other feedback too.

Here is a screenshot:

http://s421.photobucket.com/user/SharkD2161/media/LDraw/ldr_new_terrain_01_zps21c7791a.png.html

Here is a screenshot of some terrain I made several years ago using Wilbur:

http://s421.photobucket.com/user/SharkD2161/media/LDraw/town_full_lite_new_terrain_a.png.html?sort=3&o=56

I actually like this a bit better for a few reasons, but I lost the file and no longer have it. Also, WM is a bit easier to work with than Wilbur.

Mike


(By the way, if anyone would like to officially join the project, that would be awesome!)

19
Bug Reports and Help / World Machine fresh installation, won't run
« on: October 29, 2013, 07:29:59 PM »
I just freshly installed WM235_Basic.exe on a Windows XP SP3 machine. While the installation went without a hitch, when I try to run the program it pops up for a second and then disappears.

Here is what I see for that split second:



Here are my specs:

Quote
      Operating System
         Windows XP Home Edition 32-bit SP3
      CPU
         AMD Sempron
         Barton 0.13um Technology
      RAM
         2.00GB DDR @ 166MHz (2.5-5-3-7)
      Motherboard
         ASUSTek Computer INC. Kelut (Socket A)   62 C
      Graphics
         E182H ([email protected])
         128MB NVIDIA GeForce4 Ti 4600 (Undefined)
      Hard Drives
         18.6GB Western Digital WDC WD200BB-75CAA0 (ATA)
         75GB Western Digital WDC WD800JB-00JJC0 (ATA)   42 C
      Optical Drives
         TSSTcorp CDDVDW SH-S202N
      Audio
         Realtek AC'97 Audio for VIA Audio Controller

Not sure what to do next. :(

[edit]

There are a lot of zero byte crash dumps in the program directory as well.

20
General Discussion / Couple of questions
« on: October 17, 2013, 07:34:08 PM »
1. Let's say I set the horizontal resolution to 64x64. Does that mean the vertical resolution will also be 64 if I set the slider to 1.000?
2. What if I add +1 to the horizontal resolution. What will the vertical resolution be?
3. Is there a way to round the height value of each node to the nearest 1 unit?

Thank you!

[edit]

4. Is there a safe and straightforward way to split a heightfield into multiple chunks and then reassemble the exported meshes later?

Pages: [1]