Author Topic: Issue/Bug applying Macro effect to only a specific Area of the world landscape  (Read 3713 times)

0 Members and 1 Guest are viewing this topic.

Aber

  • Community Member
  • **
  • Posts: 3
    • View Profile
Hello guys,

I have an issue with using macros with Layout Generators in World machine.
I'm working on a large World map, I created continents attached to a layout generator then every time i add a new effect to the continent by using a new Layout Generator as mountains, rivers, lakes, canyons, desert...etc by using the combiner add function. Everything work as intended without any issue.







But when i try to use a macro then the macro effect will apply to the whole world instead of just only the layout generator attached to, i tried some suggestion in few posts to use a combiner as average and connect it to the Macro


This work but still add extra effect in other areas of the world, like in some parts of the continent which are still flat yet i will see some little shapes appearing on top and even in the sea level.


How do i apply the macro effect to only the area i draw with the layout generator without affecting the rest of the world? or maybe this cant be done by Macros ? Any suggestion or help will be appreciated.


Aber

  • Community Member
  • **
  • Posts: 3
    • View Profile
I've attached an example map if someone want to test.


Download the test map and deactivates the last node with the Mesa macros and look at the water level 0m all over and continent appears very flat.
Attach now the macro and you will see the sea level have few bumps and the level vary between 0m and 20 m and continents will show extra bumps too.

Aber

  • Community Member
  • **
  • Posts: 3
    • View Profile
Will there be any update for World machine to make Macros act as a mask instead of them affecting all the world, without acting as mask they are useless.