Author Topic: Bitmap Does NOT Tiles on edges shared  (Read 1294 times)

0 Members and 1 Guest are viewing this topic.

PhallundraTdB

  • Community Member
  • **
  • Posts: 2
    • View Profile
Bitmap Does NOT Tiles on edges shared
« on: August 11, 2017, 01:19:50 AM »
Hi everyone !

Im currently working on a project that need to be exported on tiled build. The problem is that the bitmap texture dosent match between two Areas. We can clearly see a cut and THAT is a huge prob !

I cannot use a blending process because of a "non-exact pixel color" issue (whatever thats not the thing.) so it is 0% . However i tried all tiles build option checked AND unchecked ("share edges vertices" and "calculate edge tiles") and nothing change, there's the same cut.  :x

If someone know what to do it'll be very very nice to help :(
« Last Edit: August 16, 2017, 12:42:20 AM by PhallundraTdB »

Teppar

  • Community Member
  • **
  • Posts: 4
    • View Profile
Re: Bitmap Does NOT Tiles on edges shared
« Reply #1 on: May 29, 2018, 08:17:43 AM »
I have the same problem and cant fix it
I havent this problem in World Creator

WM_Moderator

  • Global Moderator
  • World Machine Veteran
  • *****
  • Posts: 35
    • View Profile
Re: Bitmap Does NOT Tiles on edges shared
« Reply #2 on: May 30, 2018, 11:47:28 PM »
 PhallundraTdB and Teppar,

That's definitely what the blending option is for, so that's what I would normally recommend here. Can you explain more of your use case for the non-exact pixel color? Hopefully with more details I can be of more help!

Thanks,
WM Forum Moderator

WM_Moderator

  • Global Moderator
  • World Machine Veteran
  • *****
  • Posts: 35
    • View Profile
Re: Bitmap Does NOT Tiles on edges shared
« Reply #3 on: May 31, 2018, 06:22:02 PM »
Hey, we did some more research here at HQ and I think I do understand what you're doing. Since the original post is over a year old, I believe it's something that has since been fixed.

To not have a seam, you must use a blending percentage greater than zero. To make sure that a color value doesn't get blended, uncheck "Blend across tiles" in the Bitmap Output device.  Doing so may cause some kind of seam-like artifacts still, but it will be an order of magnitude less of a problem than not having any context shared across the tile seam.

Hope that helps!
- Forum Moderator