• Welcome to World Machine Community. Please login or sign up.
 
September 17, 2019, 12:51:02 pm

News:

Read the Development Diary for an inside look at World Machine's progress!



Post reply

The message has the following error or errors that must be corrected before continuing:
Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
Note: this post will not display until it's been approved by a moderator.
Other options
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview

Topic summary

Posted by NightGamerFX
 - May 08, 2014, 01:27:50 am
It's still not working.
Posted by WFab
 - May 08, 2014, 12:57:01 am
This happens when world machine is unable to create a directory, even in the user folder where you have access. Create the folder for macros first using windows explorer, then point to the path within world machine dialogue.
Posted by NightGamerFX
 - May 07, 2014, 05:00:13 pm
Hey Remnant, yeah sorry about that. I looked everywhere for something similar but I couldn't find anything. So I posted my own thread...Then I found this one -_-.
Posted by Stephen
 - May 07, 2014, 01:04:50 pm
see the almost identical thread and my response here: http://forum.world-machine.com/index.php?topic=2577.0

What version of Windows are you running? Try the suggested solution in that thread and see if it works.
Posted by NightGamerFX
 - May 07, 2014, 03:33:03 am
I tried all of this and it's still not working for me. When I try to change the directory it says the path is invalid...Can anyone help? I would appreciate it.
Posted by WFab
 - October 30, 2013, 04:36:45 am
just to elaborate, program files folder access is restricted to administrators...

what you need to do:

1: find your user directory for world machine. if you created with the default location, it should be <system drive>c:\users\ <user name>\documents\world machine documents

2: if you did not set it at the first run, do it now in wm... in the menu bar, click on "world commands" and go to "preferences"... go to paths and set it there

3: now copy your macro files to <your path>\macros (though they should already be there, been a long time since i set it  :mrgreen: )

4: restart world machine!

included path settings screenshot, cheers!!!
Posted by Stephen
 - October 29, 2013, 02:55:05 pm
Hi there,

World Machine prefers to have a macro folder NOT in the Program Files directory. This is because the Program Files folder is a system-protected location, and you will be unable to write or change any macros if it resides in that folder. This is the reason that WM asks to create a user's folder for you when you first started up.

Go to Preferences->Paths and make sure that the macro storage path is the directory you expect -- if you click open, it should show you the folder you posted in your screenshot. I recommend putting your macros in a user folder somewhere that WM will have full access to.

Cheers

Posted by abaldridge
 - October 29, 2013, 01:16:23 pm
So I have copied all the .Dev files for my macros to the macro folder in my WM program files.  However I am unable to see any of the macros in the library and I cannot load them into my projects device view to utilize them.  What am I doing wrong?  What do I need to do.  Here is a screenshot of my macros in the folder and my empty library. http://imgur.com/zRKk0GL