• Welcome to World Machine Community. Please login or sign up.
 
September 19, 2019, 04:32:48 pm

News:

Read the Development Diary for an inside look at World Machine's progress!



Post reply

The message has the following error or errors that must be corrected before continuing:
Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
Note: this post will not display until it's been approved by a moderator.
Other options
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview

Topic summary

Posted by Zehryo
 - July 20, 2012, 07:44:00 am
Got busy, I'm reading just now.

Yes yes, I know disabling is the way, but I had the problem just with the yellow button, that's why I couldnt understand why calculations had to involve unselected paths.


Anyway disabling all the unnecessary devices works fine, for me, so I dont feel like I need to investigate that strange behavior anymore. ^^

Thank you!
Posted by Stephen
 - July 12, 2012, 03:06:36 pm
Hi Zehryo,

This is correct -- When you press the Yellow button, it will build only those devices necessary to build the selected device. When you push the green button, it will build everything.

To be able to use the green build button but only build certain devices, put them into a group by creating a group (drag after pressing the last button under the "Tools" tab in the workview or ctrl-g), then when the group is selected hit d to disable the entire set of devices. Repeating will enable them.
Posted by Zehryo
 - July 04, 2012, 10:38:11 am
Ok, this is not an expected behavior, now..... =o

I had, I admit it, some devices still enabled, when I baked the 16k*16k pixels extent.....but they were out of the current chain!!! >.<

How could it be they got involved in the calculations? =(

Now I've disabled all the devices except the pre-baked volcano heightfield and the height output. And it actually takes like seconds and just 3 heightfields to build the whole 30x30km extent.....I'm a bit confused....

I thought, when I hit the yellow button, that WM calculates only the concurrent devices for the selected stage of the chain.
I mean, for example, if from the same device I have two different flows and outputs departing, I thought only the selected output and the preceding devices would be used for the calculation, not also the other path.

So I'd like to know if there's some "worldly wisdom" I should be aware of to avoid a very high (and useless) amount of heightfields to be used when they're not needed....
Posted by Zehryo
 - July 04, 2012, 09:37:47 am
Ok, forget about the details loss when raising the extent size, that's because of the 3D view graphic limits....silly me! -.-'

Right now I've retested it adding a constant to "fill" the empty part of the extent, but the result is the same, it takes a lifetime to, basically, add two simple heightfiels together.
Checking the build window I noticed it took up to 15 heightfields, then I just stopped it because I forgot to change the temp folder and it was creating its 12th 1GB temp file on my OS disk.

So, now, is there any way to limit the heightfields number? Just to preserve RAM as well as to speed up the whole process.....if possible.... =|

Maybe I missed some important option? Which would not be that strange, honestly.... -.-
Posted by Zehryo
 - July 04, 2012, 08:42:24 am
Hi.

I'm planning to build a ~30x30Km wide extent and I need it at a resolution of 16.384x16.384 pixels.

Luckily, part of the features are going to be isolated. Since calculating an extent that wide could take hours and hours, I was planning to pre-bake some features as separate RAW files and embed them through file input devices.

Just to see how better it would work, I've pre-baked a small 3.072x3.072 pixels volcano and embedded it in an empty 16.384x16.384 extent as explained above.

The result is that it took like 30 minutes to calculate the whole thing although a 4.0GHz i7 and 12GB of RAM @1600MHz.

Since the extent is empty and the volcano is just a pre-baked heightfield, I expected it to be pretty fast. More important, in the 3D view I had the clear impression that the volcano had lost most of its details.

So I was wondering if there's any trick to make WM calculate the least possible, when I give it pre-baked heightfields and all it has to do is pasting them together.

Maybe filling the empty parts of the extent with a constant generator....?

Thank you =)