World Machine Community

News and Development => Bug Reports and Help => Topic started by: lukieh on October 09, 2004, 05:50:57 pm

Title: "There was error saving file! Try rebuilding world mach
Post by: lukieh on October 09, 2004, 05:50:57 pm
Whenever i try to output a file to .ter (or for that matter, any file) i get this message: "there was an error saving this file! Try rebuilding the world machine." i was able to output for the first few tries, but after i started trying to use macros (i.e. the one that makes rapids) it stopped working. My computer is a Celeron 900 running windows xp w 256mb Ram.

Can someone help?
Title: "There was error saving file! Try rebuilding world mach
Post by: Fil on October 11, 2004, 01:50:58 am
Hi there,

Take a look at this previous thread (http://forum.world-machine.com/viewtopic.php?t=9&highlight=rebuilding) for more discussion on this.
But that message is due to something equivalent to there not being anything "effectively" connected to the output device or to the device you are previewing at that time.
Go through this short checklist for solving it:
:arrow: Check if there is any device connected to the input ports that device.
:arrow: Check the status (green, red/green, or red square) of every device that is connected before that one, to see if it is built or not;
:arrow: When macros are involved: in most of the cases a macro needs some input to be connected in order to output something. If it was a macro you made do inside them to check for the device that is not built.

Cheers,
Title: "There was error saving file! Try rebuilding world mach
Post by: Rhalph on October 11, 2004, 04:19:29 am
I just want to add that there mustn't be any totally red status input : That would mean there is a "connection" problem between this device and the others.
If there are some that are red/green, then these devices aren't built...