• Welcome to World Machine Community. Please login or sign up.
 
September 20, 2019, 04:15:40 pm

News:

Read the Development Diary for an inside look at World Machine's progress!


Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - monkschain

1
Bug Reports and Help / Locked out of my projects
February 15, 2014, 01:27:06 am
 Hi, I have 2.2 on C drive, and 2.3.3.1 on F.
I just uninstalled 2.3.3.1 and then installed 2.3.6.1. I installed on F again. Now when I try to open up my latest tmd WM crashes. This isn't a dev build so that's not the problem.
I then uninstalled and tried to reinstalll 2.6.6.1 on E drive instead. Again the same problem.

Now since uninstalling the F version my 2.2 won't open the tmd because of missing devices....so I just loaded all the macros into the toolbar and tried loading the tmd form there. Again, missing devices. I have not used any devices other than the following: Basic coverage, Simple Layer, Blend Layer, and possibly Coloriser2. I loaded them all in and I'm still getting the same error. After loading all of those devices to the toolbar, and restarting WM, they all disappear. I tried loading an older project and I'm getting a runtime error with that one.
I need to get multi res support, but I'm now locked out of everything. What would you recommend?

//EDIT
I managed to get into one of my older projects with 2.3.6.1 after I either added the macros in 2.2 or reisntalled to F drive. I'm honestly not sure.
I posted about this in my last post in the multi res support thread but decided to delete what I'd said because I (effectively) solved the problem by reloading  the source files again int other devices, but I didn't really get to the bottom of the problem it seems as WM is doing the same thing again. THe problem is that WM cannot find any of the tiled input source files. The stream specifiers are blank in the input devices. I don't set use relative paths when I load files. All non-tiled sources are fine. That was the problem with 2.3.3.1,. It's the same with 2.3.6.1.
I don't know what the difference between this older project that loads and the ones that crash WM are. The only difference I can think of is the new project had the tiled files relocated and loaded. It's a bit of a mess this...and it's why I stay with older builds, because I seem to get this problem quite a lot. It's probably in part due to me not fully understanding the installation process. I'd love to use the dev build (and help with development) but installing two versions always seems to create problems.

//So I'm down to using 2.3.6.1 on C only, and thankfully I've manged to get the projects back on track. You might want to look into the tiled inputs though Stephen. The other problems..well, the crashes I think were possibly created by my F drive which is an SSD drive. It seems to be a bit unstable when it's required to do anything major. It's funny how WM crashed when running from that, but only failed to load devices from C. Even though tmd and file paths were identical.

monks
2
Bug Reports and Help / Multi res support
February 08, 2014, 07:12:50 am
Hi Stephen, with the multi res support is it possible to do the following:

Import and store a terrain render extent at higher res than the surrounding terrain? In other words import high res terrain.

With a higher res terrain patch, export it and the surrounding lower res terrain as one single terrain at the lower res. So basically resample the high res and merge into the surrounding?

It'd be useful if I could set up a render extent, export that, model it at higher res elsewhere, reimport it back to the same extent but at higher res. Is this possible?

Did you implement the scale imported layout devices to new world extents? I'm still using 2.3.1 here....

Ta,
monks
3
Bug Reports and Help / Export a mesh plane?
October 14, 2013, 03:20:09 am
Is is it possible to export a mesh plane? I don't want any height, just a 2D plane. Has anyone tried this?

monks
4
 Hi, I'm new to splats so pardon me if it's an obvious question. I'm creating two splat maps (2x4). The first splat map essentially covers the entire terrain at all heights. The second splat I'd like to use for the following: Snow cover, sand, a deposition map confined to a specific area, and road placement. My first splat consists of Height, slope, wear, with transparency from a global depo map- that works fine.

I'm guessing the 2nd splat will have areas that are black- ie no cover from anything. My understanding is they will both have to be put through the same splat converter with 8 inputs. My question is, is this ok to do? Will the two separate splat maps sum to 1? will I need two transparency inputs or just one? What would I use for transparency in the 2nd splat?...I haven't really much of a clue how this setup works.

Can anyone explain?, thanks.

monks
5
Does anybody else have this problem? My alpha channel to PNG export is plugged in and yet when I open up in Photoshop cs6, alpha is not there. Yet it is there in the bitmap export. Png export it is not there. Both are 8 bits/chan.

Thanks,
monks
6
Hi, is there a way to change a shape property for all the shapes in a device at once? I've tried selecting all the shapes and right clicking shape properties but it only makes the change to the one shape. This would be a useful feature for when creating roads.

monks
7
Bug Reports and Help / resampling splatmaps
August 14, 2013, 12:07:23 pm
HI, I'm going to have to resample, (upsample) my splat maps- hopefully in WM. Are there going to be any problems with colour alteration?

monks
8
Bug Reports and Help / Adding a mask input on a macro?
August 13, 2013, 05:01:04 pm
Hi, how do you add a mask input on a macro?

monks
9
Option to set the layouts size in a layout device the same way as "Place from current" in the file input device. It would scale the layouts in the device accordingly. I have had to change the tile output sizes in my project for a game studio to a powers of 2 size, but I need 2m per pixel, so I have to change the map size. This has had the knock on effect of putting all of the layouts out of kilter.- it will take me some days to correct them  :shock:  Currently there is no way to accurately rescale the layouts so that they fit the new extents. The feature would be hugely appreciated!

monks
10
General Discussion / Tiled terrains for Unity
August 06, 2013, 05:45:42 am
Hi, I'm about to render a tiled terrain which is going into Unity. I've never used Unity before, so I'm wondering if I should set the "share edge vertices" or not in the tile export. I've posted this question over on Unity as well. Does anyone have any experience of this?

Cheers,
monks
11
Feature Requests / Curve editor graphical view
August 01, 2013, 06:10:08 am
Hey, it would be very useful to be able to span the terrain profile in the lofting curve editor so that it covers a larger vertical span. Often the terrain profile is so low along the bottom of the graph that drawing a lofting curve is difficult at best- for eg, if you have world height span set to 800m and your terrain height in the editor is only 50m. Maybe a button in the editor for display purposes only to respan the height to something useful?

monks
12
Bug Reports and Help / Drop to surface problem
August 01, 2013, 06:07:43 am
I'm trying to use the drop to surface feature because it gives better results than what I'm currently using. After drop to surface my roads are incredibly high- all maxed out to the default height of the shape it seems (here 800m).
I've set the network so that in world params it spans 0-800m. The layout road shape default height left at 800m.- just as in the tutorial tmd roads and rivers. The layout is plugged in the same way to the network as in that tut- the final terrain output just before erosion going into the roads layout.The roads layout terrain output going into the erosion.
I've tried using drop to surface in another test tmd setup and it works fine in there. I'm scratching my head as to what it could be. I did change the world height span at one point, but after rescaling all inputs, the terrain is behaving exactly as it should.
It's almost as if the drop to terrain is broken. V 2.3.3.1

monks
13
HI, option to turn off the right mouse button click that changes the display to the previous view would be a great help. This has always caused me problems reverting back to the previous view when I don't want to. I don''t know if it's my mouse button sticking or me being cack handed or what, but I used to have a problem with this with my previous mouse as well. Any chance of a setting in prefs?

monks
14
Hi, the title says it all really. I did a search on my system for the saved profile but nothing was found, so unless I'm doing something wrong, this might be a bug.

monks
15
Bug Reports and Help / Possible bug in Layout mode?
July 27, 2013, 08:49:21 am
Hi Stephen, every time I use a layout to affect the terrain in the network I get these in layout view, when I dive down to the max resolution. They appear everywhere on the terrain that the layout is connected to, not just where the layout is. I've checked the terrain output and it doesn't appear to be rendered so it's just visual. Any ideas what's causing that?

monks
16
Bug Reports and Help / 2.3 beta 3 bugs
May 10, 2012, 11:45:24 am
 Hi Stephen, found a couple of bugs.

Crash after loading a .bt with non square extents. After setting the extents in World parameters, and pressing ok, it crashed. Report sent. The second time I tried it, it didn't crash but the render extents in the Explorer views are wrong.

Hfz/2 file import problem, it doesn't load the terrain.


monks
17
Bug Reports and Help / Custom Build Res
April 01, 2012, 04:57:54 am
 I think there's a bug in 2.2 Pro. When specifying non square extents changing the custom normal build res try this: enter figures, and if you put in width x height but the width is less than the height it halves the width. If you put in the height first and it's the greater of the two numbers, WM swaps them and you can input the numbers correctly. I think that describes it. I'm not using the beta. Do you have a link for it Stephen?

monks
18
Bug Reports and Help / Y flip of tiles on export
February 17, 2012, 02:46:07 pm
Should Y flip produce this? I exported a tile set of hfz files with flip Y axis of tiles and instead of flipping the world axis, it only flipped the individual tile axis.  Using Commercial 2.2.

monks

20
Feature Requests / Import devices
February 16, 2012, 06:37:11 am
 I think it would be better if when importing devices, the World Project params didn't get set to the values of the imported network. I think this is what's happening- either that or the main extents are getting set back to the default. Maybe this is a bug?

monks
21
Bug Reports and Help / Tiling strangeness
September 29, 2011, 07:10:47 pm
Hi,..I'm trying to incorporate tiles into a larger tile set. This is proving extremely vexing...there's some wierdness going on with the tiled output

The process:
I output 4 contiguous tiles 10K from Global Mapper.

I take the bottom right tile "A" Process it and output as 4 10K tiles, covering exact same area but double the res.

Take the tile set from Global Mapper (call it "B") and output it as 16 10K tiles, again doubling the res.

I alter the tile names of "A" so that they will be loaded as part of the tile set "B", covering the same area- ...but trying to merge A into B, produces inexlicable disparities
of alignment and features.
In both A and B, I turned off Edge Blending in any file import devices.

Taking the tile 2_1 for eg...

1st tiling results for B
http://www.skindustry.net/medem/files/Temp/bug/Tile_set_1st_attempt.png

2nd tiling results for B
http://www.skindustry.net/medem/files/Temp/bug/Tile_set_2nd_attempt.png

subset A result
http://www.skindustry.net/medem/files/Temp/bug/subset_A.png

I've been at this for a week now, and I'm at a loss to work out what's going on.

monks
22
General Discussion / Sharp ridges
August 23, 2011, 08:10:56 pm
Hi, do any of you World Machine gurus out there know how to get sharp ridges from an existing terrain? I've got some terrain of some mountain ridges, but they're quiet blunt. How would I make the ridges sharper without completely altering the rest of the terrain?

Thanks,
monks
23
 Hi, I need to know how the input scaling works with a 16 bit png. Does the altitude scaling setting "specific range" map all possible values in the input file to the specified range, or does it only map actual values in the file?

Thanks,
monks
24
 Just to make sure, if I select share edge vertices in a tiled build and specify 5000 pixel tiles, then WM will create a 5000 pixel tile which includes an edge shared with the next tile? Perhaps a silly question, but I'm getting terrain into a renderer and the dev needs to know what the exact process is.

Ta,
monks
25
Bug Reports and Help / WM installation
April 11, 2011, 08:36:07 pm
 Hi, I had a problem with my new installation. WM could not copy some files to the new docs folder I created. It said I should manually copy them over. Which files are supposed to go in the docs folder please? I noticed that I can't install any macros at the moment.

Thanks,
monks
26
General Discussion / Masking Layouts
August 15, 2009, 10:42:17 am
Hi, I need to apply layouts that do not disturb existing river beds from a file input. There is no mask input on layout generators unfortunately.

I need: terrain file input + (add in combiner) Layouts - river bed mask.

Does anyone have any ideas on this?

monks
27
 Hey Stephen, I asked this question a couple of times in the last couple of months but no answers. Come on guys. I need a copy of a stable version. If I have to purchase one through the site then please tell me!

Cheers,
monks
28
Using a combination of traditional devices and layout mode shapes as masks, you can put these anywhere you like on the terrain. You can arbitrarily vary the angles and shape/ area of the incline.

http://www.skindustry.net/medem/files/Phase2/Terrain_1.0/screenies/160308/3D%20View01.png

http://www.skindustry.net/medem/files/Phase2/Terrain_1.0/screenies/160308/3D%20View02.png

monks
29
Geology and Terrain / Terrain as vector networks
December 27, 2007, 04:07:30 pm
 I've been testing out WM Pro 2.0s Layout mode, using vector splines to model real world terrain. For some more discussion on this see here:
http://terrain.cg-arts.org/forum/index.php?topic=89.0

The basic process is to use the patterns of ridges and valleys in mountain ranges as signatures if you like. It's a way of emulating the look of a terrain without copying and pasting real dems. It does have some advantages.

This is a series of zooms taken in Wm Pro 2.0 beta's Explorer mode (in which you get to fly about your terrain!). the terrain is the Misty Mountains from J.R.R Tolkien's Lord of the Rings (modelled for the ME-DEM Project):
http://www.me-dem.org/component/option,com_frontpage/Itemid,1/

The first zoom is rough but this should give you a sense of the scale of this range. It's around the same length as the Alps as it happens. Imagine the areas around the range fully modellled, hills, river courses, forests, etc
http://www.skindustry.net/medem/files/Phase2/Terrain_1.0/screenies/WMZoom_01.png

We start to see the macro structure. I've still some work to do on those- such as making certain areas higher in elevation than others- not just differentiating elevation along networks. The area around Moria (Caradhras, et al) will be more discernable as a bulge.
Also, getting the river valleys and rivers to flow naturally into the surrounding and will really help knit the terrain scene together-. Control over river flow is one of the aims.
The eastern flank (top) should rise dramatically from the plain. The western slopes will tumble down more gradually by way of the Ettenmoors, Trollshaws, etc.

The flat area to the north going off screen is the area prepped for the Grey Mts, ...here be dragons.

http://www.skindustry.net/medem/files/Phase2/Terrain_1.0/screenies/WMZoom_02.png


As you can see the valleys tend to be a uniform altitude which is wrong really- that's next on the list: finish off valleys.

http://www.skindustry.net/medem/files/Phase2/Terrain_1.0/screenies/WMZoom_03.png


This is a nice area.

http://www.skindustry.net/medem/files/Phase2/Terrain_1.0/screenies/WMZoom_04.png


Coming in to land!

http://www.skindustry.net/medem/files/Phase2/Terrain_1.0/screenies/WMZoom_05.png


monks

30
General Discussion / Scaling question
July 02, 2007, 11:03:10 am
I have a mountain which has noise and erosion applied to it via a mask so that none of the surrounding terrain is affected. The erosion takes too much height off the mountain- I'd like to be able to respan it back to the pre erosion height range but within the network. any ideas?

Thanks,
monks
31
General Discussion / Scaling Noise
May 25, 2006, 07:51:06 am
Hello, I'm using the Noise device but I need to scale the perturbations horizontally and vertically (though more horizontally)- basically large scale noise. Is there a simple device I could use to simply scale this?

monks
32
General Discussion / Seeking mountian tutorial
May 22, 2006, 06:08:05 am
Hello, I'm looking for a tutorial/ help or macro that creates mountains. There was a post on the forum but I can't seem to find it,
Thanks,


//EDIT: I found the post that I was looking for here:
http://world-machine.com/forum/viewtopic.php?t=131&highlight=mountain

but any other tips/ mcros etc regarding mountins would be very helpful :)

monks
33
General Discussion / ME-DEM Project
March 14, 2005, 12:07:53 pm
Hello, I'm just taking the liberty of letting the WM Machine community know about a project: ME-DEM (Middle Earth DEM Project). I hope you don't mind the shameless promotion   :lol:   but we will be using World Machine as one of our core apps and it may well generate discussion here in the future.
Oshyan is also involved ;) and has created a website for the project at:
http://me-dem.ashundar.com/

Thanks
Carl