• Welcome to World Machine Community. Please login or sign up.
 
September 23, 2019, 04:05:08 am

News:

Read the Development Diary for an inside look at World Machine's progress!


Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - nikita

401
Would it be good to tell my friends, that a red square said "Merry Christmas" to me? :mrgreen:

Merry Christmas to all of you!
402
Bug Reports and Help / File Input + Bitmaps
December 14, 2005, 11:13:04 am
This happend with all files i ever imported.
403
General Discussion / Rotate function?
December 14, 2005, 11:10:04 am
But I believe an integrated rotation function would be better than working with this deplacement-stuff.

Nevertheless a very clever macro.
404
General Discussion / Transformation in macros
December 04, 2005, 07:42:43 am
Ahhh... ok then  :D

(Maybe programming would be easier if not each of my threads contained a bug report or something similar...  But I have the right to do this, cause I paid for wm  :twisted:  :wink: just kidding)

*looking forward to WM 1.2.x*
405
General Discussion / Transformation in macros
December 04, 2005, 07:06:51 am
WM 1.2 comes with the ability to move the world created by a perlin noise north, east etc.  without affecting other perlins that might exist.
The same cool thing happens with gradients.

Question: Is there a possibility to influence the X and Y coordinates of a device that is inside a macro?
There are no parameter inputs for these yet.

I'm just building a crater macro using this feature and radial gradients.


btw: Sorry for always complaining.  :wink:
406
General Discussion / WISHLIST?
December 04, 2005, 03:50:04 am
I'm quite sure of this. I remember - in DOS times - you only had to keep in mind, that [Z] and [Y] are swapped on american keyboards.
Eg. You want to quit and the program asked:
"Do you really want to quit? (Y/N)"
You had to press [Z] on german keyboards.
The rest worked fine.

But an F number would also be ok. That doesn't make any difference to me.
407
General Discussion / WISHLIST?
December 03, 2005, 08:10:34 am
Yeah! I've just been playing around withe the "more nice mountains" example file. The hardness mask really would come in handy!  :D
@Fil: You mentioned this during WM98? Then thanks to you too! :mrgreen: But: The hardness parameter exists only since WM1? (At least I can't find it in my WM99)

My wish:
The key to toggle parameter inputs on or off shouldn't be [~] or [ยด] anymore.
Both only work on american keyboards. You could take a letter key for this, they are the same everywhere.

I think this would be reasonable because a lot non english people are using WM and TG, especially french and german ones.
408
Bug Reports and Help / GUI bug?
December 03, 2005, 07:54:32 am
I have the silver XP-Theme, I'll try switching to standard XP theme...
...
No - the same problem.

Fortunately, this bug is not dangerous or something.
409
Bug Reports and Help / GUI bug?
December 02, 2005, 01:30:07 pm
CPU: P3 650MHz (Coppermine)
OS: Windows XP Professional
RAM: 256MB
graphic card: Ati Rage 128

..only high end stuff...
:mrgreen:
410
Bug Reports and Help / GUI bug?
December 02, 2005, 01:05:34 pm
I don't know if somebody else has already experiences this "problem".
WM displays hints (pale yellow boxes explaining a button)

But WM always shows the hint for the button the mouse pointed at before.

Screenshots
The topmost shot shows the normal behaviour.
The second shows how it "works" when WM is running. The hint for the Inverter is shown instead of the one for Displacement (the mouse isn't visible)
Even more strange: It also influences windows' gui (see 3rd shot).

I know this bug is not important at all, but I wanted it to be mentioned.  :mrgreen:
411
Bug Reports and Help / mask problem
November 30, 2005, 11:54:05 am
Hey that was fast!  :mrgreen:
I just did some experimenting. Seems that every device, that supports masks has this problem.

After building, the device that generated the mask is marked with the green square. I suppose you tried to fix it by keeping the built mask - but it didn't work.

Well, good to know it will be fixed.  8)
(I really need ram conservation -> 256MB)
412
Macros and Plugins / Are old macros compatible?
November 30, 2005, 11:15:05 am
In some other thread is mentioned, that the erosion device of versions before WM1 will not really work on large maps.

(I can't find the thread anymore.)
413
General Discussion / Integer parameter beef
November 30, 2005, 11:07:23 am
Reduceing noise?

Take your map (let's call it "map") and invert it (call it map.i).
Add  them (map.add). The result will be totally flat.
Now blur map.i. Features of your map will become visible on the flat map.add .
If you blur more, more and bigger features of your map will appear in map.add.

So - bluring map.i just a little bit will cause only the very small features of your map to appear. Such tiny things are often noise!

So, you built a new map map.add, which has only the noise of the original map in it! Substract this from you map and the noise will be gone. (At least some noise)
414
Bug Reports and Help / mask problem
November 30, 2005, 10:52:08 am
Hey!

At first: I am an 18 years old mathematics student and just bought WM1.2 10 minutes after I opened the letter with my credit card.


I found a problem with the terrace device, but it's a general problem I guess.
I wanted the terraces only to be applied to specific areas. So i created a mask and connected it to the terrace device.
But: it won't work. I tried a different mask and still the terrace effect appeared all over the terrain.

Then I switched off memory conservation and it worked.
Soooo, i believe due to ram conservation, WM creates the mask, and then "forgets" it - in order to save ram.

Some screenshots:
http://img419.imageshack.us/img419/9551/wmbug6bx.jpg