• Welcome to World Machine Community. Please login or sign up.
 
April 21, 2019, 05:14:09 am

News:

Read the Development Diary for an inside look at World Machine's progress!


Right-Click Menu Problems

Started by jaf, June 10, 2011, 07:30:47 pm

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

jaf

This might be something on my system, but I had just added a device and then wanted to bypass it, so I used the usual right-click and selected bypass.  It worked fine, but later, when I tried to enable it, there was no right-click menu (on any device).  The device commands menu up at the top still work, as do the keyboard shortcuts.

I was running x64, so I tried x32, and it didn't even work the first time (no right-click menu.)

Seems like once it stops working, it is persistent.  Also, the right mouse button still works for moving the node display.


jaf

Just wanted to follow up on this since there were no responses.  Does anyone else have the problem of the right click menu only working once?

Stephen

I can't replicate this. I have found that sometimes right clicks seem to get lost, and I am tracking that down, but if you click again the context menu will pop up.
-- Stephen Schmitt
- Creator of World Machine

jaf

That's weird.  I just tried it again -- started x64 beta and right-clicked the advanced perlin device and got the menu. Then I clicked on a blank area to clear the menu and right-clicked the device again and no menu!

Then I exited and started the x32 version.  I right-clicked on the perlin device and no menu.  It's like the x32 is sharing whatever the problem is in x64.

Okay, now I see if I right-click several times, the menu eventually pops up.  If it didn't do that in other programs, I would suspect my mouse.

Another update.  I see now if I click fast it works all the time, but a slow right click doesn't (this only happens in only in WM.)  So I switched the right and left buttons via the control panel and now I have to click the left button "fast" to get the context menu.  So I don't think it's a hardware problem.  Guess I should unplug my graphics tablet........

jaf

I notice that the right-click initiates the context menu upon release of the mouse button, which is normal.  So it I right click but hold on a device for several seconds and then release, I don't get the menu.  If I right click and release quickly, I do get the menu.

Can someone else try a right click and hold for a couple seconds and then release?  It would seem to be a hardware problem but I can't replicate it in any other program I own.  :(

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview