• Welcome to World Machine Community. Please login or sign up.
 
June 16, 2019, 10:22:48 am

News:

Read the Development Diary for an inside look at World Machine's progress!


Problems with OpenGL-View

Started by sun-remo, December 01, 2003, 11:09:13 am

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.

sun-remo

I'm using WM for some months without any problems, now I changed to a new Motherboard and here a the problem:
switching to OpenGL / 3D-View, WM brings the system to a total halt after some turning of the landscape (I mean *total* halt -  only by switching it off I can recover... very seldom in W2K !)

Does anyone have an idea about the reason (maybe its an hardware-problem, not one of WorldMachine)

Please help

greetings

Fil

:shock:  :shock:  :shock: Ouch!

What version of WM are you using? You have W2K, right?
Odd! What motherboard is that? Do you remember making any other changes to your computer besides motherboard? Tryed new drivers for your board?

Its curious that I never thought motherboards could do something like this (sofware-specific halts)..

You say it takes a "some "rotating of the landscape for "the problem" to occur.. Without wanting to damage your computer, I suggest the following: (to try and determine what it is)
First, in WM, switch to 3D and do nothing for a long while.. See if it has halted, without having rotated the landscape.
If it didn't hang, in stead of rotating the landscape until it halts, try rotating a tiny bit, and then close WM, open WM, and repeat that in tiny portions..
If the computer doesn't hang, rotate the the terrain a bit, switch to 2D, then to 3D, rotate a bit more, and back to 2D, and so on..

The idea would be to see if it is an accumulative problem within a session of Worldmachine usage, between WM usages, or something even wierder..  I have no idea of what it could be, I'm just throwing out ideas for debugging it..

As for a fix, it will only come when fversion 1 comos out :( So my suggestion for you, when you want to use WM decently, is to use a file output device, and view the result in TerraGen or any other application that reads terrains from WM...

Send us more info as it appears..
Fil.

Stephen

Hey there,

this is a very odd problem. Do you have any problems working with WM in the workview (devices) view? Because that uses OpenGL as well, so if it was a OGL problem I'd expect it to appear there as well.

What kind of motherboard? Integrated graphics or a standalone 3D card? This sounds like some sort of hardware conflict going on to cause a W2k hardlock, but without more info I haven't a clue what's causing it.
-- Stephen Schmitt
- Creator of World Machine

sun-remo

now it works - the hint on hardware-conflicts seems to be right !

Okay, better said, its more or less a software-problem:
I used MotherboardMonitor at the same time, I shut it up and now the system keeps on working since half an hour without problems !
- twisting and turning landscapes  8)

But, to your questions about the system:
a dual-P III (Gigabyte GA 7VXTD), 512MB, ATI FireGL 2 (64MB, AGP 4x)
W2k, SP4

Problem occured with WM 0.98 and WM 0.99, other OGL-Progs run perfectly well even with MBM and other tasks running at the same time (no critics here - no program is perfect and I`m very happy with WorldMachine and all its possibilities !)

I`ll mail if the problem occurs again

thanks
Marc

Fil

I'm glad it works, at least when we want it to...

Still have no idea why a motherboard monitor program can halt a system.. unless for some reason WM prevents the comunication between the motherboard and the monitor program..
I'm estimating the monitor program has a high enough priority to be actively waiting for the packets that never arrive from the board, and then hanging the system..  :?

Anyway, you do have a nice piece of hardware there! I can't deny that! :)

Cheers
Fil.

sun-remo

bad news - after having done extensive tests with WM (doing craters on flat landscapes), I encountered the same old problem - WM is hanging my machine *totally*.

Shutting down other processes (e.g. my monitoring-prog) doesn't affect anyway - as I know so far, the system halts, when I try to view the landscape in 3d with very high zoom-factor.
That means, more or less just one "tile" of the whole landscape is visible and fills the complete window. If I try to turn, half the times I get a blue-screen "irql_not_less_or_equal", the other times the system just halts or restarts.

I guess, this might be an graphics-card-problem, not one of the system ??

greetings
Marc

Fil

ouch.. irq_not_less_or_equal, I had some of those errors some time back. I don't remember what it was.. I think I fixed it with a system reinstall :(.. But I think it had to do with my zip drive! I think sometimes I inserted my zip into the drive, the infamous blue colour filled my monitor, forcing me to reboot :-P
I guess that "irq_not_less_or_equal" is very vague for anyone to determine a problem, and doesn't provide any usefull info from the OS..
Don't know what that could be..
Fil.

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview