• Welcome to World Machine Community. Please login or sign up.
 
June 25, 2019, 08:44:27 pm

News:

Read the Development Diary for an inside look at World Machine's progress!


Zoom out

Started by Helen, December 07, 2003, 02:03:42 pm

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.

Helen

Well, maybe another dumb question :-(

I had "lost" the way to navigate in 3d preview sometime last May and many people helped me understand the way to navigate. This has worked flawlessly so far. Now, it seems to be lost again. Toggling 3d view has the camera too close to the terrain, so that it looks highly pixelated and only in part. I can scroll around by the arrows in the window. The "left click and drag" (or right click and drag) way doesn't work suddenly. I did reread the messages from that time and I am doing it the same way. Left click and drag doesn't move the view at all (or the zoom), the CPU use climbs up briefly and drops again. Right clicking (and dragging) only toggles the view.

Strangely, the navigation works on the main Window of WM, the one showing the machines and connections. I can move that right/left/up/down, zoom in and out (zoom only the machines - not the text below them) - is this normal? I have saved screenshots, if anyone is interested.

Is it something I might have inadvertedly changed? Could a macro I have downloaded have such an effect? There is a zoom one among them.

Maybe it is just a quirk of visual c (there used to be 2 versions of wm and the win2000 one had some strange effects on win NT). I haven't changed my graphic card (or updated its drivers) and no major software change or crash or anything else I can think about. I still have the same MS Intellimouse, as well.

Aren't there any keyboard shortcuts for navigation, apart from space=center?

Helen

Rhalph

Did you try to change the 3d resolution? if this resolution is too high, it may take a lot of time to refresh the view.... Go to Options -> Program Options...

helen

Quote from: RhalphDid you try to change the 3d resolution? if this resolution is too high, it may take a lot of time to refresh the view.... Go to Options -> Program Options...

That was the first thing I tried. The terrain stays immovable like a block.
Does the zoom work on the machines window as well on others, or is it just me? I hadn't noticed this before.

Helen

Stephen

There are two things I can think of that might have happenend/might help...

1) After clicking in the 3D view window, try sitting the spacebar. This should reset the navigation to its default state, if anything got funky somehow this might fix it.

2) I don't suppose its' possible that you accidently switched from the OpenGL 3D preview to the non-opengl 2D overhead view? It's the farther-right command button on the toolbar. Try toggling that and see if it fixes things.
-- Stephen Schmitt
- Creator of World Machine

Fil

Quote from: helenDoes the zoom work on the machines window as well on others, or is it just me? I hadn't noticed this before.


Yes that is true, Devices can be zoomed in, also. The early versions of WM that didn't support macros (I don't remember how it was possible to live without them ;) ) sometimes had device networks that grew in size beond acceptance. I remember moving devices one-by-one out of the way! Now we can zoom out to fit more of them in there!.. Though, I think Macros were a great discovery that tends to simplify the network a great deal.. Typically, the huge number of devices was caused by some repeated combination of devices, which nowadays can be hidden inside macros or are available in more recent devices.. So the need for zooming in/out on devices faded a bit, if you don't have a 640x480 screen resolution ;)
Fil.

helen

Well, the opengl button did the trick. I always thought that one toggled between the machines' view and the terrain one.
And zooming out on the machines could come useful.

Thank you

Helen

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview