• Welcome to World Machine Community. Please login or sign up.
 
August 19, 2019, 12:04:56 pm

News:

Read the Development Diary for an inside look at World Machine's progress!


Bitmap Does NOT Tiles on edges shared

Started by PhallundraTdB, August 11, 2017, 01:19:50 am

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

PhallundraTdB

August 11, 2017, 01:19:50 am Last Edit: August 16, 2017, 12:42:20 am by PhallundraTdB
Hi everyone !

Im currently working on a project that need to be exported on tiled build. The problem is that the bitmap texture dosent match between two Areas. We can clearly see a cut and THAT is a huge prob !

I cannot use a blending process because of a "non-exact pixel color" issue (whatever thats not the thing.) so it is 0% . However i tried all tiles build option checked AND unchecked ("share edges vertices" and "calculate edge tiles") and nothing change, there's the same cut.  :x

If someone know what to do it'll be very very nice to help :(

Teppar

I have the same problem and cant fix it
I havent this problem in World Creator

WM_Moderator

 PhallundraTdB and Teppar,

That's definitely what the blending option is for, so that's what I would normally recommend here. Can you explain more of your use case for the non-exact pixel color? Hopefully with more details I can be of more help!

Thanks,
WM Forum Moderator

WM_Moderator

Hey, we did some more research here at HQ and I think I do understand what you're doing. Since the original post is over a year old, I believe it's something that has since been fixed.

To not have a seam, you must use a blending percentage greater than zero. To make sure that a color value doesn't get blended, uncheck "Blend across tiles" in the Bitmap Output device.  Doing so may cause some kind of seam-like artifacts still, but it will be an order of magnitude less of a problem than not having any context shared across the tile seam.

Hope that helps!
- Forum Moderator

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview