• Welcome to World Machine Community. Please login or sign up.
 
June 25, 2019, 08:43:38 pm

News:

Read the Development Diary for an inside look at World Machine's progress!


crater lll

Started by Walkin' Dude, February 25, 2004, 08:31:01 am

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Walkin' Dude

Help!
Every time I try to use the crater3 macro it shuts down WM.
What am I doing wrong?
I Burn

Fil

Hi, That is odd.
Whose crater macro is it? Is it Oshyan's Crater_Macro_III? I don't recall that macro giving trouble before..
Are you connecting al the input ports?
When does the shutdown occur? when you push the build button?
can't figure out what it is from your description, can you be more specific?
Fil.

Walkin' Dude

i'm at work,so i'll check it out tonite,and reply tomorrow.
thanks
I Burn

morbidorbits

I also had this crash bug in Crater III, I totally forgot about it until now. Seems it could be a scalar splitter bug, I changed the number of ports back to the default of 3 and it works fine.

I would upload my fixed version but I don't know how ;-) Duh... is there a files area or do I need to be proficient in BBcode? HELP!

Jeff

morbidorbits

Hmmm, the version i thought I had fixed is broke again - hehe. I'm too tired to think straight right now so I will leave it for Oshyan to fix.... I can crash it with any alteration, also when I connect the 1st input port, if that helps at all? Maybe it's just some OS that crash it? I'm on XP Pro BTW.

Jeff

Fil

Well, I use W2K and it doesn't crash MW directly.. I can build and change the devices freely.. However, if after inserting the Crater_III macro I switch (file menu > recent projs) projects twice, WM crashes.. Such wierd behaviour is easily atributable to memory mannagement issues. These issues are already very keenly rewritten for version 1.0 so the problem should be gone when it comes out. Until then, there is not much to do besides improvising some strange workarround, or avoiding problematic devices. I was unable to check which devices are the problematic ones yet, so for the time being the "problematic device" is the macro itself :(
Fil.

morbidorbits

Hiya Fil, I tried disconnecting the optional inputs late last night and it seemed to do the trick. I don't have time today to work on it, maybe later tonight.

Crater2 macro works fine, get it at Rhalphs site;

http://terrafgen.free.fr/Downloads/Macros/Crater%20Maker_Mk2.dev

Hope this helps.

Jeff

Walkin' Dude

well I run XP also and it crashes, but on Win 98 it dosen't.so I'll try to work around it. thanks for all the help.
I Burn

JavaJones

Odd stuff. I've seldom, if ever, had any crash problems with version III, and I've used it a fair bit since I made it. None of the problems I ever might have had have been reproducible, either, so I've generally chalked them up to WM 0.99 weirdness, which is already well known. I'm in Win2k Pro btw.

I don't have time right now to try to create a fixed version that includes all the features of the MKIII verson, but perhaps the MKII version works well enough for now. If anyone else wants to look into fixing it, that's fine. Hopefully 1.0 will fix these kinds of things. Only time will tell.

- Oshyan

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview