• Welcome to World Machine Community. Please login or sign up.
 
October 15, 2019, 08:20:00 pm

News:

Read the Development Diary for an inside look at World Machine's progress!


Macro Library Problems

Started by jaf, May 10, 2009, 10:31:28 am

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

jaf

May 10, 2009, 10:31:28 am Last Edit: May 10, 2009, 11:38:01 am by jaf
I'm running World Machine 2.1 Pro 64 bit and can't seem to get the macro library to work.  I've copied a few .dev files I've downloaded to the default path (C:\Documents and Settings\Administrator\Application Data\World Machine 2 Professional) and also tried setting the path to a simple c:\Macros, but all I see when I click on "Devices|Macro from Library...", only one shows up on the list (Anti-Edge).  Since it starts with an "A", I assumed it was the first entry, so I changed the name to zAnti-Edge.dev and sure enough, only the next one showed (coastal-overlay).

I had 2.15 beta installed and I could see the full macro list, but I kept getting immediate crashes when either connecting or deleting the macro device.

Is anyone else having these problems?  Or am I doing something wrong?

jaf

I made a quick macro and saved it and this process worked.  But still only one item (macro) will display in the macro library with version 2.1 and all display in 2.15 beta, but it crashes almost every time I do anything, like connecting or deleting a macro.

I did a complete reinstall of WM and backed up one revision of my graphics card drivers with no change.

nikita

As you already noted, this has been fixed in v2.15 so it's not really a bug anymore. ;)
The bug is caused my changing the default macro path, maybe this helps avoiding the problem.
"Every time you read or write beyond the end of an array, somewhere a fairy dies."
Richard Buckland

jaf

May 10, 2009, 07:19:35 pm #3 Last Edit: May 10, 2009, 07:45:10 pm by jaf
Thanks.

[edit] Yes, 2.1 seems to work okay without modifying the default path.

The problem with v2.15 is it crashes almost immediately if I try to connect or delete a macro.  I just tried it again without changing the paths and it crashed as soon as I connected Dunes 6 (the first one I tried).

Nav

there are some known issues with the current "Beta" patch..esp if you are running 64bit..hopfully this gets fixed int he next patch..If i were you I would roll back to the original 2.0 version as its still working in a more stable fashion
ad

nikita

Yes, not modifying the path only helps with the macro library thing. The new problems aren't affected by this, they are different issue (that is being worked on).
"Every time you read or write beyond the end of an array, somewhere a fairy dies."
Richard Buckland

jaf

Instead of starting another thread (and sorry if this has already been covered) but is is possible to install both versions (2.1 and 2.15 beta) on the same computer?  I can see installing the beta into a new path, something like "C:\Program Files (x86)\BETA\World Machine 2 Professional".  However, the default preferences "paths" would probably interact so I guess changing the beta to non-default would work.

Also, that would probably give me a way to do macro work in 2.1 then load the tmd file in 2.15 because I'd really like to test it (2.15).

nikita

You can install WM 2.1, make a copy of the folder and then install 2.15. I haven't tried it this time, but it worked with all previous versions so far.
"Every time you read or write beyond the end of an array, somewhere a fairy dies."
Richard Buckland

jaf

What I did was completely remove WM and all directories.  Then I installed 2.1 with the addition of "\WM_BETA\" in the default install path.  Then I installed the 2.15 update to it.  And finally I made another install of 2.1 to the default path.  Then I made a couple of appropriately labeled shortcuts.

I made couple macros in 2.1 and saved them in a tmd file which, seemed to load fine in 2.15.  There's probably some interaction between the two versions because the 2.15 update can find 2.1 even at a non-default path.  Also, I noticed that both versions initially pointed to a load/save path I used before uninstalling -- guess there's an ini or registry entry I missed.

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview