• Welcome to World Machine Community. Please login or sign up.
 
August 17, 2019, 01:52:43 pm

News:

Read the Development Diary for an inside look at World Machine's progress!


Rotator

Started by lwiseman, October 04, 2011, 03:55:28 pm

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

lwiseman

Hey guys, I figured posting here would get more views.

I've generated a series of colormaps and heightmaps for a bunch of objects I wanted to place on terrains, but I wanted their placement to convey a natural appearance and having them all facing the same direction was hindering me. I found Rhalph's clever rotation macro that helped some, but it could only rotate in 90° increments. So I expounded on Rhalph's idea with this link to create a plugin that can rotate in arbitrary degrees between 0 and 45 (other angles are achievable in combination with Rhalph's macro).

There's a catch, though. Without trigonometric devices I'm losing edge information (see details here). I think it's currently good enough for my application (and possibly yours), but if someone could provide a basic trigonometric device or help me with my environment, it could be better.

lwiseman

Thanks to Remnant's help I got this to work correctly.

Before:


After:


Stephen

good stuff.

one of the things I've wanted to do in mid-term feature planning is introduce the concept of local-space maps and bitmaps that are detached from the world represented in WM. You could then, for example, splat height features around your world according to a distribution map, or do the same for texure features.
-- Stephen Schmitt
- Creator of World Machine

WizardExt

Sorry for bumping this thread, but I have problem loading this macro in World Machine. "There was an unknown error loading this macro" / "Please select a valid macro device first".

Another question concerning macros. Are they placed in the World Machine Documents folder in My Documents or where the program was installed. Both of the locations have macro folders.

Thanks.

Stephen

Hi there,

your macros are placed in the WM documents folder under your username. The one in the program files directory is the "stock" macro folder that it creates each users repository from.

Regarding the first problem, sometimes macros produced in earlier versions of WM are not loadable. When I have found an incompatible macro I have created the upgrade path so if you can post the offending one here I can see what I can do
-- Stephen Schmitt
- Creator of World Machine

jaf

Hi Steven,

I get the "There was an unknown error loading this macro." message with Rotator.  I put the .dev and .dll in     
"C:\GRAPHICS\WorldMachine\WorldMachineDocuments\Macros"
which is the path set in my preferences "Paths" for macro storage.  This is with Beta 2.3 x64.

Stephen

Ah, of course. I'll take a look and see what I get out of it.
-- Stephen Schmitt
- Creator of World Machine

Stephen

Jaf,

I'm able to load and use this macro without incident in WM 2.3 B3.
-- Stephen Schmitt
- Creator of World Machine

jaf

I still get the error but.....

Maybe I didn't install the latest update correctly.  I downloaded it and ran it over the previous beta.  Should I have uninstalled first before installing?

jaf

May 19, 2012, 04:08:04 pm #9 Last Edit: May 19, 2012, 04:12:32 pm by jaf
I used Revo Uninstaller and removed every trace of World Machine.  Then I re-installed WM2 using the the following:

WM2_Professional
WM21_Professional
WM215P_Upgrade
WM22_Professional
WM22_Professional_hotfix1

I set up the Paths as follows:

C:\GRAPHICS\WorldMachine\World Machine Documents\

C:\GRAPHICS\WorldMachine\World Machine Documents\

C:\GRAPHICS\WorldMachine\World Machine Documents\Macros\

C:\GRAPHICS\WorldMachine\World Machine Documents\Presets\

.... and then ran the latest beta...

WM23_Professional_Beta3

I installed the Rotator and .dll file in the  Macros directory
   (C:\GRAPHICS\WorldMachine\World Machine Documents\Macros\)
but still get the error message (get the same error with the x32 verson..)

Stephen

ah, OK, after paying a little more attention here I know what's up.

I was testing the macro in the first post of this thread which works fine -- the followup posted, however, depends upon having the plugin DLL available. WM 2.3 updates the core architecture and renders all previous plugins invalid -- it will have to be recompiled for WM 2.3.

So bottom line -- its just not possible to use this macro at the moment. However, as mentioned the more limited one does work fine.
-- Stephen Schmitt
- Creator of World Machine

WizardExt

Okay, thanks. I have gotten the macro to load now and also know where to place them. :)
As you said, Remnant, the macro from the first post works.

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview