• Welcome to World Machine Community. Please login or sign up.
 
October 13, 2019, 06:52:05 pm

News:

Read the Development Diary for an inside look at World Machine's progress!


8k heightmap input error

Started by Bodo Schütze, March 12, 2012, 06:18:19 am

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Bodo Schütze

Hey guys,

I'm new to World Machine and did not come far yet.

The GIS department here (University of Amsterdam) has provided me with 10m resolution DEM data for our location, I converted it to Photoshop and exported a 8192x8192 px image in 16bit grayscale.

Using the file input node in WM, nothing happens on loading or reloading. The preview image stays black. If I go out of the node and back in, it says "Error reading input file".

I tried tif, png, tga and raw each in 16 and 8 bit, bmp in 8 bit. All Grayscale.

Does anyone know, what I am doing wrong?

Greets, Bodo

Stephen

Hmm, very odd indeed.

There should be no trouble reading a 8192x8192 file.

Here's a first quick troubleshooting step. Can WM read its own files back in? For example, if you give the default world's file output a filename and type and build it, can file input read that file? This should help isolate if there is some sort of filesystem wonkiness going on.

The fact that it fails on all input types is particularly strange making me suspect the above.
-- Stephen Schmitt
- Creator of World Machine

Bodo Schütze

Good morning,

and thanks for the quick reply.

I used an 8k output file, it also works as input.

Now I replaced its content in PS (copy/paste) and saved the file. It works!

So what was wrong:

The file size of my 8k .tif map in 16bit grayscale was 414.7 MB. Using the "flatten" command, it reduced to 128 MB. WM still does not read this file.

In Photoshop 5.1 there is a difference in the file info next to the name:

My original tif: name.TIF @ 12.5% (Gray/16)
WM output: name.tif @ 12.5% (Gray/16#)

So what is the difference?? And why was the tif 400+ mb with no layers or any effects?

Would be good if we can still resolve that, even though I do have a workaround now, using the wm output as a placeholder file..

Thanks, Bodo

Stephen

wow, that's very interesting and unexpected. I am interested in tracking down what's happening here.

TIFF is a very complicated format so its at least conceivable that there could be strangeness. Could you confirm that the same thing occurs in, say, a 8 bit TGA?
-- Stephen Schmitt
- Creator of World Machine

Bodo Schütze

I flattened and converted the suspicious grayscale image to 8 bit, exported to .tga and...

..it doesn't work -.-

I can upload it to my ftp in the evening and send you the link, so you can see yourself. I'm probably doing something stupid.

But in the meantime I managed to combine my DEM and bathymetry data in WM while keeping the real world scale (close enough).

I like your tool!

Greets

Stephen

Yes, please send me the file in question to analyze. I can't replicate this issue on my side at all so it would be a huge help.
-- Stephen Schmitt
- Creator of World Machine


Stephen

I've confirmed that it happens to me too with your file but have not started an exam of why. If it is simple I will include the fix into WM 2.3 beta-3!
-- Stephen Schmitt
- Creator of World Machine

Stephen

At least for the TIF file, I can report the cause of the bug:

World Machine recognizes .tif or .tiff, but not .TIF or .TIFF. In other words, the file name comparison is case sensitive. Needless to say this can be fixed in the next beta :)

Until then just rename your file and it should work fine.  TGA, BMP, RAW, and most all the others except PNG do do a proper comparison however, so I am puzzled as to why they failed.
-- Stephen Schmitt
- Creator of World Machine

Stephen

a further followup: I've identified the issue here; it's something that has actually come up before, some of the legacy formats (BMP and TGA in particular) don't like accepting true greyscale images; the image must be an RGB or RGBA image for import. This will be fixed in the next version.
-- Stephen Schmitt
- Creator of World Machine

Bodo Schütze

I'm glad this is/will be solved. Thanks for your dedication!

I will keep posting on suspicious behavior (if I should face any) :)

Greets from Amsterdam, Bodo

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview