• Welcome to World Machine Community. Please login or sign up.
September 21, 2019, 10:40:49 pm


Read the Development Diary for an inside look at World Machine's progress!

2.3 beta 4 (graphical only) bug

Started by ronan.thibaudau, October 09, 2012, 06:46:15 pm

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I'm having a weird bug, i create a world machine file and everything behaves as expected. Then i send that file over to another computer (tried 2 diferent computers) and the following displays completely differently
- 3D preview
- 3D view
However the heightmap is the same, it's just that they get REALLY odd texturing (completely diferent to the normal height colors), also changing the extend resolution (for exemple doubling it) will make that weird texture tile over the terrain (the height will still be ok), exporting doesn't result in any issues, and the 2D view shows the correct result, so it seems to be strictly an in editor rendering issue, but worth fixing.


Very strange.

Does a terrain created on the other computer look normal or does it suffer from odd texturing? It seems like it could be an opengl issue.
-- Stephen Schmitt
- Creator of World Machine


I'm sorry i only mentioned the file transfer to clarify that the same file worked fine on computer A and not on B, but yes anything created on B or C looks wrong, regardless of wether they're created locally or not.
A is windows 7 / nvidia 540M
B is windows 8 / ati X800
C is windows server 2008 R2 virtualized on an host that probably only has an integrated chipset
The thing is it doesn't look "all weird" so i doubt it's simply an opengl issue, the height looks fine, but the texturing looks like it's made for another completely diferent heightmap (it's not jitttery colors or anything, it would look fine, on another map!)
Here are some screenshots, first is correct 2nd is wrong, looking in 3D view both look "right" as far as height is concerned, just the 2nd one's texturing absolutely doesn't match the height


Yes, its almost certainly a colormap texture application issue.. If you click the "detail texture" icon in the 3D view (last icon on the 3d toolbar), what happens?
-- Stephen Schmitt
- Creator of World Machine



Made a video to demo the issue and steps to reproduce when starting from new project, maybe some other beta users can reproduce this too?

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview