• Welcome to World Machine Community. Please login or sign up.
 
August 17, 2019, 01:39:10 pm

News:

Read the Development Diary for an inside look at World Machine's progress!


Basic edition crash on launch

Started by Lyim, October 10, 2012, 09:59:27 am

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Lyim

Hello.

First i want to apologies for my poor english :oops:

I am actually trying some landscape softwares. World Machine seem really promising but the basic version absolutly don't work on my computer.
I just want to know if this demo x86 version doesnt work on seven 64 (without warning on installation), or if my computer is simply not compatible with WM.

Stephen

Hi there,

It should definitely work on a 32 or 64bit system regardless. What error are you encountering when you try to run it?
-- Stephen Schmitt
- Creator of World Machine

Lyim

No notification, WM simply crash on launch right after the splash screen. I need to kill the process.

So if it's not a 64bit incompatibility it's my pc who can't run it.

Stephen

Very strange. What video card do you have, and are the drivers current? Often inexplicable issues are video related.

If you're running Windows 7, try installing and running within the Windows XP mode (http://www.microsoft.com/windows/virtual-pc/download.aspx). This should work however the opengl driver in the virtual machine is just software which is pretty slow.. but should at least let WM work!

-- Stephen Schmitt
- Creator of World Machine

Lyim

October 11, 2012, 12:02:03 pm #4 Last Edit: October 11, 2012, 12:06:58 pm by Lyim
Thanks for the fast answers.

GC : HD 6950 with last drivers.
Yes it's Windows 7, but home premium version, i can't use the Windows XP Mode/Virtual Machine you linked.
I have tried the compatibility mode in properties, nothing change.

My most used software are Blender, Topogun, Gimp. And i play alot with Sculptris. All work fine.
I test actually the free versions of Grome, Terragen and GeoControl without a single crash.

I don't know what is particular in WM who can't run in the same circumstances. I have downloaded it twice. Tried several reinstall, clean up the registry and temporary files between installs. Fail.

Stephen

hmm, I'm really stumped here. I've run WM successfully on everything from ancient machines with software/crude GL support to modern monstrosities. If you're using a 6950 it probably isn't video related -- I develop on a very similar system.

The only flailing guess I can make is maybe antivirus software -- try turning it off, installing again, and see if it functions. WM 2.2 (the current basic edition version) doesn't validate if all of its resource files are where they should be -- if they're messing, it fails. 2.3 changes this, but it might be possible that somehow its looking in the wrong place for its resources.

If that's the case..

Look in your %USER%\AppData\Roaming\World Machine 2.2 Basic folder and make sure there is a world.ini file there. Double check Program Files(x86)\World Machine 2 Basic\ and make sure there is a resources folder there.
-- Stephen Schmitt
- Creator of World Machine

Lyim

world.ini and ressource folder are at the right place. Avast off. World Machine still crash.

I consider a system reinstall... but in few week, i can't do that now.

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview