• Welcome to World Machine Community. Please login or sign up.
 
August 22, 2019, 05:33:48 pm

News:

Read the Development Diary for an inside look at World Machine's progress!


Macros do not load?

Started by cadmar, May 06, 2013, 05:07:07 pm

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

cadmar

Hi all,

I am trying to load a  macro that came with the WW2.3.1 install.  I am new to World Machine version 2.

I go into Devices/ Macro from library & nothing happens. Right below macro from library it says Empty Macro.

I have gone into Word commands/ preferences/ Paths  and opened the macro folder. I see the .dev macro files there.

Why will they not open? I've reinstalled WW2 3 times now. I am using windows 7 professional 64 bit. I did notice that the program, even though it says 64 bit, installed into the x86 program folder.

Thanks

Rick

Stephen

Hi Rick,

When you first installed World Machine, on first run it usually asks to create a documents folder where it will store macros, presets, and examples.

I'm assuming that this has occurred successfully, so that the macro folder that WM has in its Preferences->Paths section looks something like:

C:\Users\<You>\Documents\World Machine Documents\Macros\

If you can open that folder and see macros there, this is quite an odd situation.

More to the point, even if your macro folder is empty it should not do nothing when you attempt to load a macro -- it should just show you a blank set of macros.


As a test, try opening Preferences->paths and clicking "Set" under macro Storage :  navigate to your C:\Program Files(x86)\World Machine 2 Professional\macros folder. This is normally NOT a good idea, as user accounts do not have write permissions to this folder, but I want to see if you can view the default macros that WM ships with at that location.
-- Stephen Schmitt
- Creator of World Machine

cadmar

May 06, 2013, 06:32:30 pm #2 Last Edit: May 06, 2013, 07:47:56 pm by cadmar
Thanks for your help Remnant,

I clicked on set & navigated to the macros library. I can see the folders for coverage library & surface maps.  When I surf there from the paths I can see the dev files.

When I first installed WW2, I set the default for those folders to another drive. It warned me that the files would have to be installed manually. That was when I first uninstalled, cleaned all files to the program from my computer, rebooted & reinstalled allowing the files to install to the default folder.

What does the empty macro mean, just below Macro from library...

I noticed that the Programs (X86) folder contains the some of the same files as kept in Documents/ World machine Documents. These files are Examples, Macros, Presets and startup. tmd. Why are the same files in both folders? Also, when I add a tmd file to the sample folder, I cannot see it from within the program.

thanks again

RIck

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview