• Welcome to World Machine Community. Please login or sign up.
 
August 21, 2019, 11:45:24 am

News:

Read the Development Diary for an inside look at World Machine's progress!


Drop to surface problem

Started by monkschain, August 01, 2013, 06:07:43 am

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

monkschain

I'm trying to use the drop to surface feature because it gives better results than what I'm currently using. After drop to surface my roads are incredibly high- all maxed out to the default height of the shape it seems (here 800m).
I've set the network so that in world params it spans 0-800m. The layout road shape default height left at 800m.- just as in the tutorial tmd roads and rivers. The layout is plugged in the same way to the network as in that tut- the final terrain output just before erosion going into the roads layout.The roads layout terrain output going into the erosion.
I've tried using drop to surface in another test tmd setup and it works fine in there. I'm scratching my head as to what it could be. I did change the world height span at one point, but after rescaling all inputs, the terrain is behaving exactly as it should.
It's almost as if the drop to terrain is broken. V 2.3.3.1

monks

monkschain

August 01, 2013, 06:45:38 am #1 Last Edit: August 01, 2013, 06:48:32 am by monkschain
A bit more info on this- In the same network I just set up an advanced perlin going into a layout and the drop to surface works as expected there. I then did the same thing with an imported terrain- just replaced the advanced perlin with a heightmap- created a new road, dropped to surface, and it doesn't work with that. Layout settings were identical. I tried both hfz and bt terrains.

monks

Stephen

August 01, 2013, 06:07:50 pm #2 Last Edit: August 01, 2013, 07:00:01 pm by Remnant
Just to double check about procedure:

To drop to surface, you need to:

1) Select the device whose default output you wish to drop to
2) Right click on your curve in the layout view and select "Drop to surface"

Re-check that you're doing the above correctly, as it really shouldn't matter where the drop source is coming from, as long as the device builds. If the layout generator is the currently selected device, it may or may not work as intended; it will drop to the surface of the current layout, which may or may not be what you want (for example, you might want a drop to the input)

This is a frequently confusing point, and has dragged on unfixed for too long -- your post has spurred me to improve this! I've just changed things so that in the next version update,  you can continue to drop-to-surface exactly as above, but alternatively you can also simply select the layout generator itself (which you often will have selected anyways, to see the change results), and if that is the case it will automatically use whatever is connected as its input as the drop source. This makes a typical case easier. Finally, if no input is selected or the input isn't built, it will give an error message to let you know why its not working.
-- Stephen Schmitt
- Creator of World Machine

monkschain

August 02, 2013, 02:05:19 am #3 Last Edit: August 02, 2013, 02:11:09 am by monkschain
Cheers Stephen. That works! I'm having a bit of trouble though altering the lofting after drop to surface to get cuttings. I've tried editing the lofting curve but it doesn't seem to have an effect. I selected the device in device view to which I want the road to drop to (another layout device routing terrain into the roads layout device), then I open up the layout view and select the roads layout device, right click on the road shape and edit lofting curve. I can see the terrain and I alter the loft to get cuttings, but they're not appearing even though the lofting editor clearly shows I have done it. I've right clicked on the vertices in the layout view and they're showing the alterations I've made. It's just not getting built.
Yes, I can see why you gave the option of drop to another device for more flexibility.

AH, scratch that! The roads layout clearly showed the cuttings, but my output was going into a combiner which was bypassed but I'm guessing with two inputs the bypass wasn't functioning as I expected. Thanks for the help man, and great to see World Machine going from strength to strength!  8)

monks

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview