Author Topic: Unable to use more than 1 thread  (Read 121 times)

0 Members and 1 Guest are viewing this topic.

Michele Bedendo

  • Guest
Unable to use more than 1 thread
« on: March 06, 2019, 02:46:41 AM »
Hello there,

I purchased WM and I'm starting working with it. I got an Indie license so I should be able to use up to 2 cores/threads. However, it seems I'm still stuck with only 1 thread. I tried to set in the Preferences, under Build Options the "Maximum Worker Threads" to 2 but I only get 1/1. I have a Ryzen 1700+ 8 cores / 16 threads so I have plenty of cores/threads to use. Any suggestion to what I'm doing wrong?

Thanks in advance  :)

Cheers.

Stephen

  • Author
  • World Machine Guru
  • *****
  • Posts: 2320
    • View Profile
    • http://www.world-machine.com/
Re: Unable to use more than 1 thread
« Reply #1 on: March 07, 2019, 02:49:24 PM »
Hi there,

Hmm, something is definitely going wrong here, hopefully we can iron it out quickly! A few questions:

1) What build of World Machine are you running? (Listed in Help->About World Machine if you don't remember)
2) In the Preferences->Build Options dialog, are you saying the slider only has a single notch of 1/1? Or that when set to 2, you only have one build thread functioning?
3) With World Machine closed, open the file "%APPDATA%\World Machine Standard\world.ini and find the line System_thread_max=  . Make sure that it is set to 2, and save. Open World Machine, and try building a world. Do you get both threads functioning?

-- Stephen Schmitt
- Creator of World Machine