• Welcome to World Machine Community. Please login or sign up.
 
October 13, 2019, 06:55:10 pm

News:

Read the Development Diary for an inside look at World Machine's progress!


Memory Leak?

Started by bvz, February 07, 2006, 01:39:05 pm

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

bvz

WM has been running for several days without being restarted.

While trying to build a 4k map, it was reporting over 1000 heightfields active and was running out of memory instantly.  

I then created a new file by doing a save-as, and deleted everything except for an erosion node.  Note that I did not restart WM.  It now ran without complaining about the memory, but still had listed well over 1000 heightfields active.  It also said well over a gig of memory was being used.  After a bit, I cancelled this build, but the app froze up and I had to kill it.

Upon restart, opening the original file (before deleting everything), I hit build and - lo and behold - it worked.  It maxed out at 86 heightfields active and somewhere around 400MB of ram.

I will now keep an eye on this to see if there is actually a leak, but I thought I would post this info.

Ben

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:

Shortcuts: ALT+S save/post or ALT+P preview