'Could not create libary file'

Your bug report should include:

  1. https://gyazo.com/605a4293f0d97e2ca82fddc807a854d3
  2. I dont know why this is suddently happening, cant save macros anymore. The paths are correct.
    I Have no clue how to resolve this.

Zhyrr

Hi there,

A couple ideas:

  1. You said this started suddenly happening - you were able to save macros correctly before?

  2. If your macro folder path is valid, can you confirm if it includes any unicode characters in the path or not? I have a suspicion that this might be a unicode path getting mangled. Try setting the macro folder to an ascii-only path name and see if it works

Hey,
Yes I have saved plenty of macros before.
What is an ascii-only path?

If the file path contains a character not in the western european character set (Latin-1), the save operation might fail. This is because WM is (up to build 3028) built on an older framework that doesn’t handle internationalization properly. Try creating a simple folder under C:\ called, for example “macrotest” and setting the macro folder to that location.

Another possibility is that an antivirus software or something similar is sandboxing WM and preventing it from creating a file in the location you’ve specified…

Thanks that was it!
Just created a simple Macro folder in my /:smiley: folder

Glad that fixed it for you!