Geoglyph macros 'invalid'

Hi all, I’m thinking about getting Geoglyph but I got the trial version and can’t quite get it to work. Any time I try to load a macro, an error pops up saying the macro isn’t valid. I’ve downloaded and used several user-made macros without problem, so it seems to only be the Geoglyph macros that are causing the issue. It looks awesome and I’d really love for it to work but I can’t get it to work for the life of me. I’ve tried running things in admin mode, relocating the macros and pointing both programs to new folders (on the c: drive, another internal drive and a NAS) and I get the same result every time.

I’m using World Machine Standard and the free trial of Geoglyph. Thanks in advance.

Hi, I have the same problem. double click on to a node crashes the software everytime.

I realise that this is quite belated, but what is the actual build number of your WM?
GG2 only works with WM 2.3.7 and up.
Earlier version crash…

I also have both free versions - current editions - and am running into the same issues mentioned above - def proving to be a pain in the @$$ to get working correctly and the install process is not user friendly at all. Like it tells me to install it to a folder - when i run the program its like nah fool - you need to move a macros folder to this other spot - and then when I try to load geoglyph it wigs out and nothing works. Anyone who knows how to make both free trial versions work together with a step by step guide would be a HUGE favor to the over 5000 people who have viewed this post…

Your website is a good web site. There are many useful information for us.