High res build out of memory

I ve tried 16k build (system memory 64GB, estimated memory use 190GB). I was expecting lots of disk swapping, but build fails on out of memory (latest WM). If I remember well, it was possible to build over your system memory in older versions. Bug? Feature? I am not sure I can use tiled build in this case, since I use create water device.

Thanks for the potential bug report - I’m improving the paging system in the next build so I want to verify that things are working as intended in it.

Yes - it should page out the current build results as the build proceeds, as needed; I just realized that it’s possible that LTE may not be paging out the build results from the current build-in-progress however; I’ll double check this.

If the current build results are not being paged out, then even with windows doing virtual memory, 190GB is likely too much to handle.

Does your render extent have memory-conservation enabled? This should allow you to build even quite extreme size worlds, since only the final result is kept.

Yes, It was turned on. It is just complex project. I think the best solution would be make all devices tiled build compatible:

I have a suspiction there is some memory leak. I made this out of memory build, then opened other instance of WM and run 4k build (estimated memory usage 1,5GB with final build) and it went out of memory too. I neded to restart PC. This never happened in 3.x versions, I could have in parallel several instances of WM without any issues.

It’s unlikely to be a memory leak; I’d actually expect what you described to occur.

In short, the only time WM (should) report it ran out of memory is if the OS itself fails to provide any additional memory; for that to happen, WM’s own purge & paging system has failed to free up any space, and then Windows’ virtual memory system has filled up, and there’s nothing left to be done about it.

In that case, it’s a global machine issue, and your other running programs will also face allocation failure as soon as they try to get equivalent amounts more memory (multi-GB).

(This is why having WM do its own paging is important; the OS virtual memory system can easily hit its own limits with these kinds of over-allocations.)

The estimate shown in that project settings page is 192GB used; How much physical memory do you have? Is that estimate size anywhere near the size of your available RAM + windows swapfile?

One current issue we’ve uncovered is that the current LTE builds are not paging the currently-in-progress build to disk, only prior contents. This is a deficiency vs WM 3.x; that gigantic world can’t be paged as it builds, and that probably explains the difference you see. This is corrected for the next build, which should be out this week.

Hello, as I told, I have 64GB of ram. Windows swap file is set on automatic size. It is on PCI 4.0 SSD HDD with 800GB free space. I understand that 192GB build is too much and it would require serious changes to code to be able to overallocate so much and survive swapping, but what is wierd, that it also failed to build 1,5GB build in second WM instance. This means, that after failed build in the first instance memory wasnt freed and restart of PC was necessary. Unfortunatelly I forget to check system resources. So looking forward to the new version.

I have to solve this via tiled build anyway (my production build will be 32k), I just have to remove all devices which are not supporting it. Create water will be replaced by manual rivers and I have to export all expanders to file and load it as file input (btw, making expander tiled build compatible is other point worthy of attention). Thanks!

I ve tried latest build and it seems, that issue is gone. 16k build would probably finish. I had to cancel it in 1/2, because flow restructure would take cca 400 mintues (3 minutes in 8k, 30 sec in 4k, so there is something wrong).