Missing Macro Parameter WM4027

Your bug report should include:

  1. What happened: I brought out a macro I’ve made in WM4020 to see how the parameters are dealt with in the new build and noticed one of the exposed parameters did not identity itself correctly when I hovered over the parameter port. The parameter was “Shapeguide lead in level” and when I connected an Integer Generator up to it, it did not receive the set integer internally.

  1. Does it happen consistently, or randomly? I have not checked other macros for similar occurrences. If there are steps to take for more information, I’m happy to try them out. Since it might be an issue with just this macro, I’m posting the .tmd I was working in: dev fiddle 211027 01.tmd (8 Bytes)

  2. The steps to reproduce it. Include a screenshot or world file if possible: Oh, I just did that. Heh. :sweat_smile:

Looking at the file size, there may be another problem here. 8 Bytes seems small for a .tmd with one mountain build already in it. The file might not have saved anything in it, which means no debugging on this problem and the work I’ve done (along with the test of that macro) will be lost as soon as I close WM. I can at least attach the .dev file for that macro: Fast Terrain.dev (101.4 KB)

That was weird… I deleted the macro, tried to save, and this time it worked. I re-loaded the macro (same parameter is blank) and it seems to have saved. So, here’s the file: dev fiddle 211027 01.tmd (347.6 KB)

@davidroberson Sometimes, devices inside a macro need a “version update” before they can operate normally with the new version. It may change the “character” of your output though, as nearly 50% devices have been improved between 4020 and this one. Best to keep things separate between the stable and development build, a general rule of thumb. I personally use Alpha and Dev builds for all personal projects, there’s always something that has a potential to glitch when you work across versions this far off.

1 Like