Problem Importing .tif generated in Agisoft Metashape

I am new to World Machine and I am having trouble importing a DEM in .tiff raster format generated from Agisoft Metashape.
I want to import the DEM and edit it in World Engine.

When I import the .tif DEM, no terrain is displayed, only a while block (maybe max value?)
Any suggestions would be helpful.

Thank you,

Here are some screen shots of this issue and the export options from Agisoft and import options in World Machine. I tried to add some images in the previous post but I do not see them displayed.

I imported the .tif into ArcGIS, and the file is displayed without a problem. I tried exporting it in different formats to no avail.
When trying to import each file, I tried adjusting the altitude scaling with no effect.
I am currently running World Machine Professional Build 3025 ‘Alpine Lakes’ 64bit.

I’m trying to recreate this .obj model as a terrain in unreal engine or unity.

You need to rasterize DEM data into a heightmap before importing into world machine. Geotiff is not supported yet, you need the regular baked Tiff16bit (floating) heightmap. Are you sure that you used correctly rasterized tiff file?

Ah ha! These are 32bit I can give this a try, to you know of an application that does this well? Photoshop?

I Haven’t tried any for a long time, since I make my own terrains from scratch mostly, but you can try “xnview” or “imagemagick”.