Reconstruction type: 'faster (linear ridges)'

I’ve run into an issue where the masking of the erosion device is not working, but only on one side of the scene.

I’m working on a map with a specific heightmap input. Some area’s (as marked) are underwater. The height of the water is critical for gameplay - therefore I’ve masked those bits off.

This is an overlay view with the used erosion mask. I’ve made sure that (even though the terrain underneath is not) that the mask is symmetrical - there should be no differences there.

image
Left side before (top) and after (bottom) eroding
image

image
Right side before (top) and after (bottom) eroding
image

Its a bit hard to see without the A/B comparison but there is sediment being placed there even though the mask is completely black.

I’ve tried changing the randomness seed and the problem keeps happening. I’ve re-processed the terrain a few times at different resolutions and the problem keeps happening.

After testing a bit more while writing: When I pick a new erosion device the problem disappears. I’ve limited the issue to the reconstruction type of the geological time enhancement being ‘Faster (linear ridges)’. When I select that option the entire top-right part of the map appears to be behaving quite different to the bottom-left part of the map, including ignoring the erosion mask.


Reconstruction type as ‘faster (linear ridges)’ (top) and as ‘better (smooth ridges)’ (bottom)

This fix works for me, but I suspect the behavior of ‘faster (linear ridges)’ is unintended so I am still posting the report :slight_smile: .

1 Like

You will see erosion channels and deposits in any area that has even a slightest bit of gray. Only areas with values at absolute zero, don’t get any erosion. That’s intentional.

That said, I can’t recreate your issue. Also, have you tried using “coastal erosion” node for your water body needs?

I’m attaching a file where you can play around with the mask softness to see its effect on erosion.

Erosion masking demo.tmd (60.6 KB)