River device WM crash

I used functionality “split reach at vertex” in the place of two rivers connection and device went crazy. It stopped visualy responding on spline changes, it ignores CGS and attempt to load CGS crashes WM. Something is probably somewhere cached on hdd, because after loading WM again (and restarting PC), it behaves in the same way and crashes again. Copying of device didnt help, not even from older version of project. I tried running older version of project (cca week old), but it also crashes. I checked temporary files locations (set in project settings), but it was empty. I tried even older version of WM (4017). But result is still the same. Where WM caches this device? How is it possible, that it also started to affect older backup of project? I had to create new river device and draw all rivers again.

Hmm. There shouldn’t be any kind of persistent cache or anything like that; the sole exception is within the temp folder, the autosave file which will contain the last committed change. It shouldn’t have affected the project file or anything like that.

I’m currently working on a few bugfixes for the river device, I believe the crash/GCS ignore issue is the same one I’m currently working on. If so, the root cause of this should be fixed in the next release.

2 Likes