Scene View Gamma Difference

Your bug report should include:

  1. What happened: I don’t think this really counts as a bug, so much as a question about the difference between an Overlay and Scene View of a given texture. The example I have has a relatively light albedo, as shown in the Overlay View (see screenshot) but the color is darker and more saturated in the Scene View. I did not connect a shadow map, but I did use AO (which seemed to lighten things a bit more than it was without it).

  2. Does it happen consistently, or randomly? I have not had a chance to create an alternate scene to test this out further. If it’s just a property of how materials are rendered in PBR mode, is it safe to assume the same asset would render as darkly in another application? I’ve run into trouble with producing accurate colors due to things like monitor settings, which can sometimes force me to correct for it sort of by eye using a reference color table or something like it on a screen that has bad color (usually because I can’t change the settings it’s using).

  3. The steps to reproduce it. Include a screenshot or world file if possible:

If the Scene View has the exact same input as the Overlay View (ie just a terrain and a texture, no additional inputs or material data), it should produce the same result.

I can’t see your device network, but I suspect the differences you’re seeing might be due to the AO and/or turning the raw diffuse texture into a material…?

Edit: One other thought is if any of the components in your graph would flag the output as ‘unlit’; this is a hidden attribute, but it is applied by the lighting generator, if one is in the graph.

I’m in a different project at the moment, so I can’t grab a quick screenshot of the graph, but there was a lighting generator (disabled or disconnected) from an initial attempt to use a shadow map off a Channel Splitter. I’ll go back and play with it again to see what else is configured the way you guessed. I think I tried feeding the texture in directly and through a Materials node, and both looked about the same, but I ran the AO and Normal the same way for each setup, either as direct connections or thru a Materials node.

Okay, I went back and poked around a bit, and discovered that the hard shadows come in when you hook up the Normal. Edit: In particular, it seems to be an issue with a normal created directly from the height. If you use the normal created with Meshify, it lights pretty normally. Here’s the .tmd: dev fiddle 211027 01.tmd (348.4 KB)