Tiled build fails

I’ve been trying to do a tiled build for the Mountain Texture Showcase using the Alpine Lakes 3028 build. It always fails with Tile 0,0 not able to finish the blending phase (everything else builds successfully). I have tried various tiles sizes and number, always the same result. Memory isn’t the issue.

Hi there,

The Water devices do have some problems with producing proper results with tiled builds - they are marked with a (!) in the device view for this reason - but it usually is more of an issue with regards to accuracy – in short, the drainage area calculated will be wrong if there are large drainage basins off-tile. Increasing the tile blending percentage will help with this.

With all that said I can’t replicate this issue. Can you share your modified world file that exhibits this problem for us to replicate?

This world is slightly modified, I have sent the output of the water device to a mesh export and build 4x4 files at 4096. The resulting screenshot:

Mountain Texture Showcase.tmd (130.2 KB)

I took a look, I believe what’s happening here is that the Mesh Output is failing when building tiles that have no river data in them; it’s not distinguishing between a successful export attempt with no data, and a failed export attempt.

I’ll see if I can get a bugfix for this readied!