Tips for Troubleshooting Crashes?

I’ve got a map that is very build-resistant. It crashes randomly at varying points throughout the build. Since it doesn’t keep crashing on a particular node, I’m not sure how to troubleshoot my node graph.

I’ve got 32gb of RAM and have set WM to use 75% and have enabled paging. However, the max memory used at a typical crash is about 24gb and no paging has yet started. I tried lowering the WM process priority to Low as recommended in an older thread but that did not make a difference.

I’m not sure how to proceed to fix this map.

That’s a bummer… :confused:

Does WM give you any meaningful error message? Maybe you can limit the maximum number of devices to be built at once. Maybe a part of your RAM is faulty, is there a way for you to test the integrity of your RAM modules?

1 Like

Hi there,

I’m very interested in any world that consistently crashes, as this should not happen. :slight_smile: There’s nothing I can do about video driver issues and such, but my goal for fundamental WM operation is that it should never crash.

Can you send the world file and replication instructions to and I’ll take a look at it?

1 Like

My bet, it’s a “paging to disk” issue.

  1. Either wm is not allowed to “page to disk”. Could be that the setting itself is disabled, disk is full, disk is failing, path is inaccessible.
  2. Or it’s a bug related to paging.

@drose25 Try this. Raise the memory allowed to “80%”. Does that change the crashing parameters? If yes, it’s a paging issue. If it still crashes at 24 GB, one of your memory modules is degrading quickly. Time for a memory check. If something else happens, its something unexpected, more research required.

Im on around crash # 70 for today… super annoying… my memory is fine…
Those new wires must be the cause.

I appreciate the suggestions, WFab but I’ve tried all of them already. I double-checked that WM was allowed to page to disk and I even unset it, saved, and reset it to make sure it wasn’t “stuck.”

I originally had allowed memory set to 95%. At that point, it was crashing at around 29-30gb of ram. I backed it down to 75% in case it wasn’t getting enough time to initiate paging before capping out or if it was squeezing out some other process that was causing the crash.

I’m going to run a comprehensive memory check overnight but I’m not expecting to find anything. I’ve routinely hit 8-30gb memory usage with Blender and some other apps without any crashes.

1 Like

Well, I ran Passmark’s MemTest86 overnight and it found no memory issues. It may just be my Rube Goldberg blend of logic in my graph. :stuck_out_tongue_winking_eye:

1 Like

99% of the time random crashing during build is almost always a running out of memory situation, especially random crashes during build that only occur during high res builds.

Normally WM can make better swapping decisions than Windows, but if you’re encountering a swap crash:

  1. Make sure your windows swapfile is set to a large enough size
  2. In WM program settings, turn off “Allow WM to page packets to disk” and try to rebuild. This defers all paging to the OS. This is usually significantly slower (as Windows might try to page out data that is still needed), but should allow the build to proceed, as long as your swapfile is large enough.
  3. Contact, as these crashes should not exist and can be fixed. :slight_smile:

That’s awful. Is the crash reporting dialog appearing for any of these crashes, and if so, have you reported them? The expected number of crashes using WM is 0. Whatever action you’re taking is clearly triggering a bug in some codepath that hasn’t been exercised and that I would love to fix.

I sent the project… and in my frustration started everything over… its quite complicated what I am trying to do… I tried to explain in the email… If I had a super power… it would be Bug magnet