WM crashing at launch

Hi,
I’m not sure if this is a bug, but I was working on a scene in WM, I hit a button ( I can’t remember what button) and WM crashed. Now everytime I try to launch it, it crashes. I’ve even tried startup.tmd to launch, but same thing.

If you accidentally hit the text output button, that seems to cause a crash loop within WM, though I don’t know if it brings up the crash window. In any case, try clearing out the temporary files folder (default location is, I believe C:\users\[username]\AppData\Roaming\World Machine Release\temp ). If that fixes it, you should be set, failing that, send the crash data for analysis if you haven’t already (I can confirm that this data is actually analyzed as I’ve gotten emails saying that crash data I’ve sent has helped with a bug fix), and reinstall. If none of that works, update here and I can try some more troubleshooting steps!

1 Like

Thank you for your suggestion. Unfortunatly, there were no temporary files, hidden or otherwise, in the location you specified. I’ve gone ahead and opened a ticket with the latest crash log. Fingers crossed, that they can figure out the issue.

Ah, that’s unfortunate that that didn’t work. While you wait for a response (and possibly before reinstallation, if you haven’t tried that already), try going to C:\users\[username]\AppData\Roaming\World Machine Release and rename the file world.ini to something like world.ini.bak and see if that fixes things for you. If so, something was changed in your preferences that caused this crash loops, so I’d make sure to document any program settings you change before you change them so you know what’s causing it if it happens again in the future.

Thanks again Blattacker. As you suggested, I changed the name of the file world.ini, then tried to launch WM, but it’s still crashing at launch. Do you think doing a simple uninstall, then reinstall fix this?

I would definitely try that if you haven’t already! Be sure to back up any macros or blueprints you’ve created or downloaded beforehand, as I’m unsure if uninstalling will remove those directories.

Well, that didn’t work. I uninstalled WM, then reinstalled it, and it’s still crashing at launch. At this point I’m completely at a loss. Last week I submitted a ticket, but I still haven’t gotten a response.

I got a response from Stephen which fixed the issue. Below is his response for anyone that runs into this type of problem.

Sorry to hear you’re having trouble! I’m not certain which version you’re running, but WM is supposed to count its start attempts and stop trying to load an autosave if it keeps crashing the program. But something may be going wrong with that…

So, if WM previously worked, but doesn’t now, there must still be some files present causing trouble.

1) If you’re using the Development Channel, make sure you remove the folder named “World Machine Dev” in your %APPDATA% folder. Likewise, the standard release channel information is in “World Machine Release”

2) Older versions used a different naming scheme for their settings. Just in case, delete any folder from %APPDATA% that starts with “World Machine…” :slight_smile: This will cause WM to act like you’re installing it again for the first time.

3 Likes