WM4 crashes my world upon startup

Hey all!

  1. What happened

So, yesterday I worked on my world again and was copying some example worlds into my own world and playing around with them there so I can see what impact it had on other landscapes etc.

A new mouse which I ordered arrived and I plugged it in, used it a bit with WM4, set my PC to sleep mode and went to lunch.

After I turned my PC on again, I couldnt start my world again. It crashes everytime I open it.

  1. Does it happen consistently, or randomly?

It happens constantly upon startup, but only with my own world.

  1. The steps to reproduce it. Include a screenshot or world file if possible

Here is the world file: New Project.zip (791.1 KB)

Here is the WM log: worldmachine_log.zip (960 Bytes)

  1. I dont know if it is because I´ve plugged in a new mouse, which I already tried replacing, or because a device is causing this problem. I´m also using Win 10.

I hope someone can help me fix this problem.
Thank you!

Hi Patrick,

A couple things:

  1. When you say upon startup, do you mean that you can’t open World Machine, or that when you go to open your world it crashes?

  2. From the log file, it looks like you’re using build 4016. The first step is updating to 4017, as it includes many bug fixes that may address your problem.

Hi Stephen,

thanks for the quick answer as always. Its really amazing how much you care about your community.

I meant either the autosave after a crash or manually. So I meant the world file not WM itself.

I tried it again now and for some reason I was able to start my world again so I guess it fxed itself (?).
However, I did update now and its running smoother and without any hickups anymore so maybe that really was my problem.

Anyways, thanks for the answer!