World Machine 2 Release Countdown Thread

I’m having the same problem on 64-bit Vista. I’ve tried running the 32-bit version and it also asks for Username and registration every time I launch WM2.

Vue has the same problem and the work-around is to run it as administrator.


having the same issue of having to re-enter my details on every launch. i’m a vista home premium 64bit user. having looked at the world.ini file. theres a space where my details should be. so i’m gonna take a wild guess at it being to do with security settings and placing world machine in the program files folder.

latego is right. right click on the worldmachine exes. select properties. select compatibility. then tick “run this program as an administrator” box.

That works, thanks guys!

Yup. Worked for me too, many thanks.

Hey guys,

interesting that neither myself or any of the beta testers used Standard (non admin) accounts to try that one. :slight_smile: I’ll pin it to a FAQ list for WM2.


All works here! Happy 4th to all!
My first attempt :smiley:


Remnant i am running as an admin account and i still had that issue.

Me too.

Interesting… are you running under XP or Vista? I’ve tested on both with no problems, but those were both on admin accounts.

Vista 64bit, and launching the 64bit version of World Machine.