World Machine crashes on startup

After installing the latest Windows 10 updates, World Machine crashes on startup on loading any TMD file. Even the example files bundled with the application are affected.

The crash does not occur when opening World Machine from its application shortcut, and then opening a TMD file from inside the application. However, an alert is throw:

image

Tested Windows version: Windows 10 v. 2004, OS build 19041.508.

The issue does not occur on the development channel beta.

World Machine version: World Machine Professional 3028 64-bit.

Hmm, strange. Please write down your system specifications in case that helps solve the problem.
Have you tried doing a clean reinstall of WM 3028?

Yeah, I actually formatted my Windows box and updated it fully, and the problem remains.

Operating System: Windows 10 Pro 64-bit (10.0, Build 19041) (19041.vb_release.191206-1406)
Language: English (Regional Setting: English)
System Manufacturer: Micro-Star International Co., Ltd.
System Model: GE75 Raider 9SF
BIOS: E17E2IMS.115 (type: UEFI)
Processor: Intel® Core™ i7-9750H CPU @ 2.60GHz (12 CPUs), ~2.6GHz
Memory: 16384MB RAM
Available OS Memory: 16230MB RAM
Page File: 10968MB used, 7692MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Supported
DirectX Database Version: 1.1.5
DxDiag Version: 10.00.19041.0488 64bit Unicode

    Card name: NVIDIA GeForce RTX 2070
    Manufacturer: NVIDIA
       Chip type: GeForce RTX 2070
        DAC type: Integrated RAMDAC
     Device Type: Full Device
  Display Memory: 16145 MB
Dedicated Memory: 8031 MB
   Shared Memory: 8114 MB
    Current Mode: 1920 x 1080 (32 bit) (144Hz)

I believe we’ve already discussed this in the support ticket, but echoing here for others to find.

It appears that Windows 10 Build 2004 may be breaking something inside the MFC framework that build 3028 and prior relies upon. I’m currently investigating, and will try to issue a patch if possible.

The LTE builds 4000+ are not affected by this issue.

2 Likes

FYI
I can load my Project without errors.
But I got the same error when I try and SAVE . To get around it I now use SAVE AS.
image

I’ve tracked this one down.

As near as I can tell, the latest OS update now uses some code that requires a particular initialize() call to be made but does not do so, causing this error. This is highly annoying as it breaks back-compatibility of every MFC-based app on windows, including World Machine.

I’m testing a patch now that should resolve this, Hopefully Microsoft will patch their own changes soon, but that’s not something that’s easy to count on :crazy_face:

1 Like

A patch is now available to fix this: