Automation block help <location>

Hello, Im trying to setup a automation block to changes the render rectangle. Ive tried both x y coordinates and kilometer values as described in the documentation.
x0 y0 x1 y1 xy coordinates as listed on the documentation do not work. However
0 0 12 12 runs but Im getting a

“malformed format string in modify renderextents block”

My xml looks like this:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<automation version="WMP2">
<load file="WM_FILE_02.tmd"/>

<section name='Tile Build'>
<echo text="Starting  tiled build"/>
<extent index="0">
<location>0 0 2 2</location>

<build mode="tiled"/>
<echo text="finishing tiled builds"/>

Any idea why this wouldn’t be running or failing on the format? Thanks!

Tested on my own install and the provided code seems to work correctly, so I’m guessing there’s something going wrong somewhere else. What version of World Machine are you currently using? Are you running this from the command line or from the GUI? Did you use the .tms file extension for the script? And just double checking, you’re running at least the professional license, right (as the indie and community licenses can’t do tiled builds)? The only way I’ve been able to force the build to fail so far is to have forbidden characters in the naming structure for the tiled build, so maybe check for that (though the error I got was different)?


ah thanks! Ive tried both command line and GUI. Its generates the same error in both. Im running professional version WM2 3020. However the name structure could be the issue. I have generated my own node for exporting for different path results and naming than the built in world machine…I might guess this could be why. I’m going to give it a try with the built in world machine node.

1 Like

That seems likely to be the issue. As a test, I just downloaded the 3020 version of WM, and the code still executed properly on my end.

Just in case, I also tested the same script on WM 2.3.2 and 2.3 just in case I was misunderstanding version numbers, and the script executes successfully on both.