Can't activate license and no response from support


We bought world machine pro license. When we try to activate it, we get “Could not communicate with activation server” error.

I have sent couple of support emails, but no response. Please help. We are just stuck, and this sucks

Ticket id: 221412

A few things you can try at your end:

  1. Disable fast boot, and restart your PC. Start world machine with admin privilege on the first run.
  2. If that doesn’t work, check your firewall settings. Both third party, and windows firewall. Disable both and try again. If it works, time for digging in and making new rules for world machine license server. If it still doesn’t work, there’s another solution, but it’s drastic.
  3. LAST RESORT: Delete contents of this folder - “C:\Users\All Users\Reprise\worldmchn”. Then restart your computer. Once the power cycle is complete, then start world machine as admin. It will ask for your license info again, so keep it ready. WARNING: If it breaks your installation, uninstall world machine, and reinstall.

If all this fails, it’s either a genuine bug, or a problem with permissions over at your end.

Good luck!

1 Like

Thanks @WFab

It seemed to be an issue with our office firewall. We had disabled the firewall on the PC, but still, it was not working. We switched to the mobile network, and it worked.