Caves and Waterfalls

Helllo Everyone,

New to World Machine and started my journey about three weeks ago because I got tired of making node based landscapes in Blender and wanted to make the workflow more streamline. I was wondering is World Machine capable of creating waterfalls or caves? I have been doing some tutorials but most are out of date with the exception of Geekatplay’s. I just feel like World Machine can do so much more and that I am just scratching a minimal surface with it. I miss the old days of Bryce.

Caves are not possible in World Machine as the terrain is based on a 2D heightmap which cannot show any kind of overhangs or the like. Waterfalls, however, are definitely possible, though I’ve never attempted to make one on purpose, I should give that a try…

Editing to add @HYLK has an excellent modern tutorial series that should help you get at least started and on your way!

2 Likes

I tried several of his time lapses but the gap between the version number he is using and the most current things do not even come close to what he gets. I started some of the Geek at Play ones and got close results to the tutorial. I also purchased his newest course by Valdimir Chopine (GeekatPlay) which matches the most current version of WM. He also explains certain things pretty in depth. The only way to make caves that I learned in Blender was to take two maps and flip them on their respective axis and sandwich them, I was checking out WM and I think there might be a way. At least I believe there might be with the devices because the inverter flips a height map so there has to be another device that should allow an offset or mapping of a terrain. Coming into this software being wet behind the ears and trying to cram it feels pretty overwhelming, almost on the same level as trying to learn texture nodes in Blender or Houdini with no experience.

I am also trying to figure out how to make alien landscapes in WM for some animations ideas I have.

I’m not quite sure what you mean by this, but I believe HYLK’s tutorials are using Artist Pointe, or at most one version behind. The Geek At Play videos on YouTube (at least, if they’re the ones I’m thinking of) were made before the LTE version of World Machine was released. Are you saying that you have an older version of World Machine? If so, the device explanations may be of more help to you than the timelapses.

I don’t mean to crush any dreams you may have with this software, but it’s simply not capable of displaying a cave. It’s not a matter of workarounds or processes, it’s just straight up (currently, who knows in the future) incapable of it.

I found out what the problem was I had to buy HYLK’s macro pack in order to follow along correctly in some of his time lapse videos. I use the most current stable pro version of WM.

Understood that WM cannot make caves, I came up with a worklfow using 3D coat to sculpt the cave, retopo it and the export it to Blender as an fbx. It’s a lengthy process but works better than trying to sculpt it in Blender (too much fiddling).

I do have a side bar question though, I was working through a tutorial using the NASA dem files and when I use the file input device in WM the import looks like nothing but spikes. Is there another device I have to use in order for the dem file to display correctly in WM (most currrent stable version 1/22/2022 I believe it was).

That’s mostly going to depend on the file itself. Theoretically, the dem file should display correctly, and my first guess is likely a scaling issue. Do you have an example of a dem file (or the specific one you’re using) that you can provide to help with troubleshooting?

I have attached the screenshot of what happens when I use the File Input device with the NASA Dem file. I noticed I cannot upload the dem file due to its 20MB size. It looks like just a black screen which has the geographical data to create the terrain. But I have no idea why its doing what it is in the screen shot. Because the person who did the tutorial did it with an older version of WM and he just plugged the Dem file into the file input device and it worked.

That definitely doesn’t look correct. My guess would be a faulty download/corrupted file. Are you using the same dem file from the tutorial? If so, can you link to the tutorial, I can see if I can replicate the issue from that.

I downloaded it from the actual website just like the person doing the tutorial. Here is the site https://search.earthdata.nasa.gov/. Then I used the file input device and got what you seen in the screen shot. I was messing around with some of the devices which I am not too familiar with since I have had WM pro for about three weeks now, and learning something new everyday with it. The weird thing about those Dem files when you open them up to look at them it’s almost like there is no data but when I loaded it into Affinity and then added a grayscale filter or the light dark filter then you can just barely see the lines in the actual picture.

One other thing the guy said to use the Aster file type, I just ran a test even with the Num file type and got the same exact output. The weird thing is the early version of WM handled them with no problem and displayed them correctly with just the file input device and no tweaks.

That’s super interesting! The File Input definitely works properly, but with files specifically downloaded from that source, they seem to bug out. A quick workaround I found is to just open up the file in literally any image editor (I tested with Photoshop and Microsoft Paint, both worked) and, without changing anything, save the file. When it’s saved by any other software than whatever NASA is using, it loads in just fine. The Elevation data is a bit…odd, though.
I think something has changed with how NASA stores or encodes the data, because I have some old DEM files that I’ve downloaded from there that seem to work just fine in newer versions of World Machine, but so far, everything I’ve downloaded today is acting strangely. I wonder what’s happened?
Have you tried getting dem files from USGS rather than NASA?

I went to the USGS site but its a bit convoluted, spent the better part of 15 minutes looking for the correct height maps, all I keep getting are the regular map files which appear to be xeroxed maps of the real thing. When I did a search this is where I landed at USGS map downloads

Here is the USGS site I went to which is appearently their homepage, having problems trying to locate the dem files, getting everything but them

Just finally figured out USGS and downloaded a Dem file, put it into affinity photo because GIMP didn’t want to open it correctly. Didn’t touch anything inside the file and renamed the file and saved it as a TIFF. Ended up with the same crazy stuff, I think at this point I will just throw all my efforts into using the generators to get some kind of landscape.

Yeah, this is definitely very odd. You seem to be on the wrong part of the USGS site, but even going to the correct part, every image I’m downloading right now seems to be coming out as pure white or pure black, if I can download them at all. Several of the resources I used to use for working from real life terrains (literally less than a year ago) fully don’t work at all anymore. I’m thinking possibly something has changed with how they’re recording the data. The issue doesn’t seem to be with WM. I’m gonna try going the QGIS route and seeing if that at least still works, if so I can give you a basic rundown on how to use it to grab real world data.

In the interim: this site works to an extent. So far I’ve been able to click on a tile, hit the “Preview Image” (actual download buttons don’t seem to work right now), and download the jpeg version of the height data and have it work out of the box. Note that it’s definitely not an ideal situation, and you probably wouldn’t want to use these maps in a production environment, but if you’re just looking to play around with them, it’s better than nothing!

QGIS route definitely works, and will likely work with any of the geoTIFFs you’ve already downloaded (it’s worked for the two I’ve tried, specifically from the USGS site, but I haven’t done extensive testing yet).

  • Simply download QGIS, install it, open it, drag and drop the file you’re trying to use into the program (or use the built-in file browser to navigate to the file) to open it.
  • If you want to use the data as-is, just right click the layer on the left-hand side, go to the Export submenu, “Save As”.
  • You can leave all settings as default and just select where you’d like it to be saved as well as the filename you’d like, hit OK, and you should be good to go.
  • The file exported from QGIS seems to work natively in World Machine with the File Input device.

If you’d like to crop out a section of the downloaded file, you’ll want to (after loading up the file):

  • Head up to the Raster submenu, then go “Extraction → Clip Raster By Extent”.
  • Once there, on the “Clipping Extent” line, you’ll want to select the drop-down option button next to the text box, and select “Draw on Canvas”. This will let you manually select the area you’d like to mask out for export.
  • Once done, click the “Run” button at the bottom of the dialogue box.
  • You’ll see a new layer on the left hand side, the top-most layer is your cropped extents that you can now export as above and use in WM.

I’m working on finding out if there’s an easy and effective workflow for using the LiDAR point cloud files for even better results, but that could take awhile.

(Edits for clarity, links, and formatting)

It works but I am getting the white area around the clipped entent area, I followed the steps exactly and when I export the software seems to want to take that white area around the clipped area. When I imported the clipped region that white area places the landscape into what looks like a white box. LOL. Is there some option in the QGIS software to omit the white area during the export?

Nevermind I figured it out there is a selection box in the export dialog that takes that away.

1 Like

If you’re describing what I think you are, I think I avoided that by just disabling the underlying layer before export, but I’m not completely sure, as I didn’t run into that issue. Glad it’s working for you now!

Thank you for all your help, it seems to be working. I also learned how to stitch the surrounding areas of the map into a bigger scene which helped out immensly with this method you found.