How to add sea level water to the scene map/create water node


I’m currently struggling with producing the water surrounding an island using the create water node. I’m generating it from a pre-existing heightmap and raising the sea level but the sea level water doesn’t appear in scene view and I can’t figure out a way to create this sea level water to add as an existing body of water.

The Erosion node shows roughly what I’m aiming for, it’s a modified heightmap of australia, flipped and with higher sea levels.

What I’m actually producing in the scene viewer doesn’t have the same sea level and shows where the water would flow below sea level.

I think I need to create a body of water that is at the sea level and combine them but I’m not entirely sure on how to proceed with that, although possibly using the sea level I’ve set might be easier but I don’t think I can view it in the scene view. This is the current set up I have.

Any help you could offer would be great, thank you.

@conor202 There are multiple problems with your approach. While you’re not wrong, I’d rather use this method to approach a terrain.

  1. “World moving” nodes like “sea”, should always come first when it comes to “create water” based workflows.
  2. Most erosion types can take in a water input, so you need yome water present in the scene before erosion, if you want to make good use of this tech. Erosion will then “flow” into water bodies generated.
  3. “Sealevel” guide shows only if the checkbox next to it is checked on. You can use this guide using “coast erosion” to generate water, and maybe beaches. Coast erosion can take the height from sealevel guide, and generates “sea water” in the process.

Follow this screenshot:

1 Like

Ah that’s great thank you! The coast erosion generating the sea water is really useful.

I am struggling to connect the nodes in the manner shown however, I can’t connect the water output of the create water to the erosion node, is there a setting in the nodes I’ve missed?

@conor202 Make sure you’re connecting the water, to “sediment removal” port of the erosion node (3rd one).

If you can’t connect still, some screenshots may help solving the issue.

Thanks, yes it was the sediment removal port, it doesn’t want to connect the water output to the heightmap input.

Here’s what I’ve currently got (sorry it is a little messy looking at the moment).

What’s your world machine version? If that’s okay, you can PM me the tmd file. I’ll check it against the latest stable version on my end.

Thanks, that would be a great if you would be able to take a look at it! I’m currently on ‘Mt Rainier Build 4020’

@conor202 I just checked your project. Right click your erosion node, go to “Choose device version”, and set it to the latest (3026 in case of 4020 build). Then you’ll be able to connect water to the sediment removal port.

It’s good practice to check device versions for updates, there’s a menu entry somewhere for version manager, that lets you update all nodes in your project at once. You probably started this project in a previous version, then opened the same project in the new version. That’s where this problem came from.

Happy building!

1 Like