Masks from WM don't match UE4 map

I have created a flow that takes a heightmap.r16 and slices it into above water and below water, then those two branch to two slope filters for shallow and steep. From there I route to height outputs for all 4 slope modules. This should give me 4 paint masks suitable for import to UE4. I have done this in the past in WM2. With WM Mt. Raineer it is not working so well.

The output files look good in GIMP but when I import them into UE4 they are all off by several meters to the left. So -5 or -8 meters off from center, or they are all of scale. I have tried offset and scale adjustments but have not found any that line it up yet.

I have some screenshots and the world save if anyone else wants to verify it.

Input file and project are both 8192 x 8192, 127, 2x2.

Not sure if I did something wrong or if this is a bug with the export.
HeightMapGenerator.tmd (81.1 KB)

So far the exports look fine, checked your file.

That said, if the problem only appears in UE4, the problem is probably somewhere in your UE4 project. Some things you can try:

  1. Is your landscape object shifted from the center? Double check it’s location and rotation.
  2. Start with a fresh project for testing. Just import your landscape, and test all your masks as an overlay texture. Try not to move from world center.

That should help you figure out the issue. I’m sure it’s something obvious like this.

Thank you. I will try a new world tonight for testing. I will let you know the outcome.

1 Like

When I make a new world in UE4 8129 x 8129 is the max. In World Machine I can only choose 8192 x 8192.

This I think is the issue. Scale is slightly off between the programs. Was this a typo in the programming?

8129 (UE4) or 8192 (WM). That is a 0.76% difference in size.

I was able to adjust my Texture Scale to 0.993 and that got the masks to line up so it is an issue with the conversion from WM using 8192 to UE max at 8129.

1 Like

@truwrecks You can set your world machine project to UE4 friendly resolution. Just above the resolution slider, click “Power of two” to get a dropdown. Set it to “UE4 Landscape” to get 8129 resolution project wide.

Here’s a screenshot of that setting.

Thank you very much! It is working great now!

1 Like