Splatmap/Colormap loose alpha channel in tiling

I would like to tile pre rendered terrain splatmaps and colormaps, however the created tiles do not have an alpha-channel anymore. It seems setting the file input RGB does not include the alpha-channel.

Is there a way to tile splatmaps/colormaps in WM without loosing the alpha-channel?

Hi there,

Can you explain a bit more about what you’re doing and what’s failing?

So, it sounds like you’re importing already-made splatmaps and want to modify them. Are you using the Tiled File Input device or the File Input device?

Hi, I’m using the file input to load previously generated splatmaps and colormaps in 8K to tile them to 2K. The input is set to interpret as RGB, however when I tile the splatmap and colormap, they loose their alpha channels.

So if I’m understanding the setup correctly:

The bitmap output from the file input device exports the RGB channels of your file; the alpha channel is exported in the extents mask output, so the 4th channel of your splatmap can be found there. (splatmaps “overload” the meaning of the alpha channel to be a data channel instead of a mask, as WM normally assumes it would be.)

Preserve your alpha channel by connecting both ports to the output:

Okay, I thought as much, however if I’m using this configuration, the tiled image gets distorted, and semi transparent.


Left side is what it looks like in original/without alpha, right side is with the alpha provided as shown.

The tiled Image has an alpha now when saved as .tif (duh) however it is not arranged properly it seems.

The splatmap/colormap tiling is somewhat weird as well, it repeats itself partially. Could it be that the coordinates are messed up? Because that used to work before. The heightmap tiling works just fine.

After some more testing, here’s what I found out: Alpha Channel is lost when tiling is saved as .png, only 32 Bit .Png can have Alpha so that’s my user error. Save as .Tif instead.

However after tiling I realized the Alpha Channel is not applied properly, it is flipped vertically and from the wrong partition element. I. e. X0Y0 Alpha was applied to X1Y0. I learned that by comparing the original alpha mask with the created partial one and matched them up. I’m using WM Pro 3027 btw.

Edit: Fixed it! The option “import into landscape” was causing this issues for the maps, disabling it resolves tiling issues, the Alpha Maps however are put into the wrong tiles and are flipped vertically. So in order to arrange that it needs to be tweaked in Photoshop. Thanks for the assistance.