WM closes immediately after I open it

As the title suggests, World Machine closes immediately after I opened it. I have the free World Machine Basic Build 4031 installed, I have reinstalled it several times and tried other methods (deleting the world.ini file from %APPDATA%, checking whether s mode was on in windows, updating the drivers). I have opened a ticket in the WM user support but they have yet to respond so I am asking here in hopes you guys will manage to help me sooner.
I use windows 10 (specs: Intel(R) Core™ i5-9600KF CPU @ 3.70GHz 3.70 GHz ,RAM: 16.0 GB, System type: 64-bit operating system, x64-based processor), and I don’t think that I have any problem with my computers.
It is worth noting that I had used older versions of WM on this computer a long time ago.
Help?

Do you have any older macros like geoglyph or others currently installed? Those are usually the reason for those startup crashes. Check the “worldmachine_log.txt” located at “C:\Users(username)\AppData\Roaming\World Machine Release” for a comprehensive error log.

Artist point release is not compatible with a lot of older third party macros. Official macros shipped with the installation are okay, they’ve been updated for the current version. Best to move the older macros to a different location from default (Documents\World Machine Documents\Macros). Then add the important ones, one at a time, to see if they crash during startup.

1 Like

It worked! I reset my World Machine Documents folder and it launches now. Thank you so much!

1 Like