World Machine Crashes when working with high resolutions

Hi,

I keep getting crashes when working with the newest version (4031) of World Machine. It is not super consistent and doesn’t happen everytime but it does happen every now and then. I am working with quite a high resolution of 16k and it doesn’t seem to happen with smaller resolutions. I have 128GB of RAM but maybe there is some problem with the memory handling or the disk paging, because sometimes world machine falls back to disk paging due to the high resolution.
I attached my crashdump and also screenshots of my working file. There are two bigger networks but the bigger one is actually deactivated and not used and only the smaller one is being computed. The network itself is nothing special I think.
Anyone experiencing the same or maybe @Stephen knows what might cause this?

Thanks!
wm_crash.zip (556.2 KB)

I am making some more tests and will provide more insights here:

  • I just tried to build the network bit by bit by just manually writing height outputs I spread across to disk to see inbetween states. It went well so far but once I hit a regular build to finally build the rest of the network that was leftover, world machine crashed. I am using minimal memory conservation mode atm.
  • Cleaned up my file by removing all the deactivated parts. A build with maximum memory conservation went through without a problem.
  • Did another build with the cleaned up file with minimal memory conservation. World Machine had to page to disk and crashed again. The hard drive is neither full nor broken and the wm temporary files folder is set to the same hard drive wm is installed on (C:_scratchdisk\wm_temp) worldmachine_crash_date22-03_25-15-50.zip (237.3 KB)

So from the current tests it feels like the disk paging might be causing the crashes.
Update: Just stumbled over this thread and will try around with the recommendations posted there.

Hi there,

I have a fix in progress for a paging crash that can sometimes occur when building very large networks. The thread you linked above has the currently recommended workaround; let me know if that does or does not fix the issue you’re running into!

2 Likes

Another test I made:
Increased allowed memory usage in WM to 80%, manually set windows swap file size to initial 50GB and max 128GB (I have around 100GB of RAM available and roughly 200GB of harddisk space left). Building with minimal memory conservation. Unfortunately still crashing.

Is it actually important that WM pages to the same hard disk as it is installed on or can I also use another one? Or would that hurt the performance a lot?

For the next test I will turn off to allow wm to do the paging and rely on the OS. @Stephen how confident are you in your fix and do you have an eta for it? :slight_smile:

Turn off WM’s paging system in the program settings. This will punt all out-of-memory conditions to the OS as noted in the other thread, which is usually slower but should work around the issue for now.

You can set the temporary folder to any drive in Program Settings, strongly recommend a SSD.

The fix will be in the next available build; no ETA on exact timing on that yet.

1 Like

Okay so the test with turning off WM’s paging system worked. The build also wasn’t that much slower and no crash occured. Thanks for the help so far and I hope the upcoming fix will resolve that issue :slight_smile: