How Do I Add Rivers from a File?

Okay, so I made exactly seven attempts to use “Load Reach from File” in the River Device, and each time had to restart WM.

I tried

  1. a 256x256 svg with black background and several rivers in white
  2. a smaller sized svg 64x64 with one river in white
  3. a yet smaller size with one river, and a transparent background
  4. an image of the same size in dxf format
  5. changed the river color to black
  6. …etc.

Can someone @WFab, @blattacker, @HYLK, WM developer, please help with what is required to successfully load a reach from a file into the river device in WM? Thanks.

@Jillinger Yeah manual rivers crashes more often than any other device for me too. I’ve never tried loading a reach from file, and the option is grayed out in the latest stable build, for me at least.

Rather than going into depth about the current issue (since I know very little about manual rivers), I’d rather ask a few different questions. What exactly are you trying to create, what version of world machine are you using currently, and what’s the process or approach you’re using? I may be able to suggest a different workflow.

Yes, I installed the latest version earlier today, and realized that feature was grayed out, perhaps because it doesn’t work in the earlier versions.
I wanted to create a scene with many rivers, and did not want to draw each by hand.
I started out with the WM Basic 3020, and that’s what I was using.

@Jillinger The latest version of world machine has “create water” node, that creates automatic rivers based on your terrain. It doesn’t have finer controls like manual rivers, but is great for quickly populating your world with rivers.

Here’s a quick demo on how to use it. You can adpt your own project to use this workflow, if river channels are all you need. You can use various techniques to extract masks for river bank etc.

Create water demo(WFab).tmd (271.0 KB)

1 Like

That’s similar to this I think, but thanks. The water device is the solution. I had my focus on the wrong device. :smile:
I also just thought of how I can place rivers exactly where I want them, without changing my terrain. :sunglasses:

Edit: @WFab
One thing I observed in your example, is that rivers flow uphill, unless you create an unrealistic possibility.

1 Like

That is strange. If you use the Flow Restructure device and directly afterwards the Create Water device, it shouldn’t be able for rivers to flow uphill. In general, the Create Water device will not create rivers that flow uphill, but if you take the water output and, using the Scene View device, lay it on top of a different terrain, you can get “uphill” rivers, so my question to you is, does your node setup in essence look like below, or is something funky going on?

I meant WFab’s example. I didn’t change anything. I just downloaded and opened, and I can observe the flows uphill. In the 3d view, I can see it clearly. Don’t you see it?

I can’t see it, yet. Been looking at it from all angles for the last 10 minutes.

Rivers do flow uphill slightly, when flow speed is increased. But that’s just for maybe 5 meters or so. That said, I think it’s an illusion. River is flowing downhill, but but either terrain profile, or the way I set up texture, is making it look a bit funky. Like I said, it’s a quick example, feel free to play with it to your heart’s content. That’ll help more than any wall of text I can type ever will lol! :rofl:

@Jillinger Found a single tributary that looks like it’s going uphill. Built 8k for closer inspection, turns out it’s not. It’s just laying flat. The POV angle, or perspective, makes it look tilted.

Besides this, I think the water is behaving plausibly. Feel free to correct me if I’m wrong.

The technique itself should be useful though for your own project. Play with the settings in this test, you may learn a lot more this way. Try disabling “geological time enhancement” inside “erosion” device. It’ll change the terrain profile, but may sit nicer with rivers. Also, play with the seed value in “advanced perlin” device, try different base shapes. This is the beauty of non-destructive modeling!

You are correct. Lol. I am seeing things. :laughing: I was not looking at the finer trails as the source, but rater, the destination.

Now I think about it, that’s realistic yes, but it’s also realistic that the source starts fine, while the destination, over time, will increase, even becoming a pool, at times.
So my world was upside down. Lol.

1 Like

@Jillinger Lol! Yeah there was a bug in this build which made “flow particles” disappear, which makes your confusion not that odd.

The later versions will have an animated material, as well as particles to show flow direction. And so far it works as expected! Still in testing as of now, may land on “dev channel” soon. Here’s some stuff I made using the alpha builds, will give you a better glimpse into the future!

Open links in new tabs for the forum post.

Nice effort. I haven’t tried anything to show, so I can only talk. :wink:
Looking at the trails in the mountainside, I was thinking it would be nice if you had depressions on the mountain top, where water might settle, and gradually make trails down the mountain’s face.
Otherwise, having just a handful of valleys carved along a few areas of the mountain. Sort of like this.
However, you may not be striving for realism, more than visualization, and I am too much of a perfectionist - not a very good thing, so don’t mind me. :smiley: Just do what you are doing.
They look nice. :smile:

1 Like

@Jillinger That’s some decent feedback, thanks!

No, I’m never going for realism, since I’m really bad at “scaling”. Usually, I’m going for “plausibility”. Those aren’t mountains in my mind, they are barely “hills”, iced over, and mixed with snow. Was inspired by a documentary from Antarctica. There’s some unique landscapes over there. The water in this scene is just “melt water”, very small scale channels. If you look carefully in the last iteration, volume is preserved. You can see Ice melting, and flowing into those channels. That’s what I was aiming for, and that’s what I got! I’m done with the “design” part for both of them, will try for more complexity for the next one.

Didn’t link it for attention though, just wanted to show you what the future versions of world machine have in store. These projects were merely “field tests” for the test builds. Though now I’m working to make them into reusable assets. We’ll see what becomes of them lol! :thinking:

1 Like

Now that you explained it… I have the full picture. How easy it is to do so when one has all the facts. :+1:

1 Like

I’m pretty sure the option is greyed out in Mt. Rainier and Artist Point. I would have to run each to be sure. I did visit this thread hoping to learn how to use it. @Stephen, is this a feature that will eventually be coming back into use? I doubt it’ll come in with any version of Artist Point, being sort of off topic there, but at a guess will it be more than a year’s wait at the earliest?